1

I have both Python 2.7 (which comes with ArcGIS) and 3.7 (which comes QGIS 3.4) - in normal command prompt its showing Python 3.7.0 and path from qgis 3.4. I confirmed version and path running following commands

python 

>>> import sys
>>> print(sys.path)

python version confirmation

so I tried to install PyQt5 by the following command

pip install PyQt5

but the command prompt throws the

DEPRECATION : Python 2.7 will reach ...

error.

pip installation error

So as command prompt suggested I tried to upgrade the pip version by using following commands

python -m pip install --upgrade pip

but again I got the different error like

already up-to-date

updated error

I don't know what to do. Is there any problem with Version (2.7 or 3.7 issues) else am I doing mistake on installing/setting up with environment variables.

Note: I'm in the process of developing a tool which uses PyProj, GDAL, so I used Qt Designer for front-end. trying to convert UI to py. I'm a beginner so messed-up with these things.

  • 2
    You'll need to open the osgeo4w shell and execute py3_env.bat to activate py3 in that shell. Did you? If you want to use Pyqt5 you have to run qt5_env.bat before running pyrcc5 or pyuic5. – Andreas Müller Aug 7 '19 at 13:22

Browse other questions tagged or ask your own question.