0

I had assumed it was an error due to lack of space but no matter where we try to save it we get the folllowing error:

Traceback (most recent call last): File "C:/PROGRA~1/QGIS3~1.8/apps/qgis/./python/plugins\processing\algs\qgis\Heatmap.py", line 210, in processAlgorithm self.tr('Could not create destination layer')) _core.QgsProcessingException: Could not create destination layer

If the layers are different CRS's (even in a CRS that worked with version 2.16) it runs and saves in the right places but we just get a giant egg shape instead of the nice heatmap we had before. I understand this is due to the meters/degrees difference but still it runs so that's better than the layers which should be in the correct CRS which just error and don't run at all. If its a space issue why do the ones with the different CRS run but the correct ones not?

Any ideas?

  • 1
    it is most likely no space error (checked your hard drive if you have enough space?) have you tried "on the fly" heatmap creation like explained here (works only in newer QGIS versions) qgistutorials.com/en/docs/creating_heatmaps.html – sn1ks Aug 7 at 11:53
  • check the projection units. If you instruct to make an output with a cell size of 1 covering the entire world, it will work when using degrees but will likely fail if using meters. – JGH Aug 7 at 12:17
  • The heat map plugin isn't available on new versions is it? – Belinda Aug 7 at 12:20
  • we need to be able to interpret the data beyond the simple styled option unfortunately but thank you for the suggestion... If it is just the space issue, why does it make a heatmap (as wrong as it is) when the units are in degrees rather than meters (results in a giant unhelpful egg)? – Belinda Aug 7 at 12:23
  • 1
    Screen samples would be a big help here. – Stu Smith Aug 7 at 15:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.