I have created a map with multiple points and path layers in QGIS 3.8 (Zanzibar). When I try to publish the map with the QGIS2Web plugin, there are two kind of results:

  • When I use the "OpenLayers" option, it works quickly and it shows the raster map and the paths perfectly; however, only four of the many (>100) points are shown.

  • When I use the "Leaflet" option, it does show all the points (although extremely slowly), but no raster map, and the functionality is really poor (very slow and barely visible).

I prefer to use the OpenLayers option, as it worked perfectly, except for all the missing points and labels.

Could anybody tell me how I can fix this?

The underlying dataset seems to be fine, as all the points are shown in the Leaflet option, and also when I load them in Geojson.

closed as off-topic by Ian Turton Aug 9 at 14:24

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This problem cannot or can no longer be reproduced. Changes to the system or to the asker's circumstances may have rendered the question obsolete, or the question does not include a procedure to enable potential answerers to reproduce the same symptoms. Such questions are off-topic as they are unlikely to help future readers, but editing them to include more details can lead to re-opening." – Ian Turton
If this question can be reworded to fit the rules in the help center, please edit the question.


Update: the problem is fixed! I saved the layers with the missing points, which were previously saved as .csv files, as shapefiles, and uploaded the map with OpenLayers, and it worked perfectly.

Not the answer you're looking for? Browse other questions tagged or ask your own question.