I have added a table from Access to ArcMap, and then used 'Display XY data' to plot points. When I then try to export the Events to a shapefile I get an error message telling me:

"Error exporting data. Create output feature class failed"

Followed by:

"Warning: Some records may not have been exported correctly."

and then:

"There was an error exporting the layer."

Can anyone tell me why this is happening, and how I can export my data?

I was able to export an almost identical file this morning with no problems. I'm saving straight to my C drive, so no unusual characters in the files path. All the fields are either text or Long types, and none have long names/unusual characters in their names.

I've tried restarting ArcMap and my machine, and exporting to several different locations.

I'm using version 10, with Access 2007, and there are 7332 points in the table.

  • 2
    there are some 'null' records in your event layer (from access).
    – Mapperz
    Sep 10, 2012 at 15:34
  • Some records have null values for some fields, but none are completely null Sep 10, 2012 at 15:36
  • 5
    Coordinate fields must not be null. Even one blank record will cause this error. Unexpected value may also cause this error. Ensure both X and Y coordinates have consistent numeric values. Sep 10, 2012 at 16:04
  • Jakub is correct if any 'null' records exist the export will fail.
    – Mapperz
    Sep 10, 2012 at 17:48
  • Is there any log file to help debug this error?
    – ed22
    Apr 27, 2020 at 9:43

8 Answers 8


I had this exact same problem today. It wasn't permissions, it was weird characters in my data. As it turned out, I had pound signs (#) in the labels column and when I got rid of those, the shapefile export worked perfectly.

  • +1 Thank you for sharing your experience--it may help others. Welcome to our site!
    – whuber
    Nov 6, 2012 at 22:42

My guess is that you may have blank spaces in your column headings. Try replacing them with an underscore

  • I don't have any spaces in my field headings. I was able to export an almost identical file this morning - it had the same field headings and number of records. Sep 10, 2012 at 15:48
  • 4
    Does ArcMap let you save it as a DBF file without any problems? Try this: blogs.esri.com/esri/supportcenter/2012/05/24/…
    – Rayner
    Sep 10, 2012 at 15:55
  1. If you zoom to the extent of your xy data,
  2. Then select the window so you only get the records you want.
    (any way you can get that selection is acceptable).
  3. Ensure that the mxd projection is set to the projection you want to output.
  4. Then export the data from the table of contents (not the attribute table).
  5. Make sure that you use the selected features and the data frame for theprojection.

I have faced the same problem, you can solve it by one of the following:

  • Check the name of the table which you are joining with (In my case, I renamed it from Arabic to English, then the problem solved).
  • Check the name of the fields within the table (no spaces, no symbols.. etc)
  • Check the permission to the destination folder/drive you are exporting to.

I've found that my problem was caused by trying to export the data to a location I didn't have permission to save to.

The error message in ArcMap obviously didn't help uncover that issue - it came to light when I tried to export to a dbf from my Access database.

  • I was going to suggest it was a permissions issue, but figured it wasn't the case since you said you tried "exporting to several different locations." You should mark this as the accepted answer, so that it can help others who may have the same question in the future.
    – user3461
    Sep 11, 2012 at 11:14
  • 1
    Yes, I think my initial attempts to export were to somewhere I should have been able to save to, so I'm not sure what the problem was then (possibly a conflict with the file name as I had previously exported and deleted the file, and I've found that does sometimes cause issues). After restarting ArcMap and the machine, I only used the non-savable location... I'll accept the answer once I'm allowed to tomorrow. Sep 11, 2012 at 13:15

To me below steps worked!

  1. Be sure all field names(column names in the excel/csv) are of length 1-10 and have no space in them ( use _ instead) details are here.
  2. Be sure file (excel/csv etc) name follows arcgis path rules (e.g. no space etc)
  3. Be sure sheet (excel etc) name follows arcgis path rules (e.g. no space etc)
  4. Be sure all field data are formatted as text
  5. Be sure added xy layer attribute table has attributes not blanks(see attribute table in the table of contents).

If all above are ok then no matter you want to export added xy layer into featureclass or shapefile.

N.B. I tested in arcmap 10.3

  • Thanks. I found my problem is the length of the field names.
    – Tianxin Li
    Dec 16, 2016 at 20:15

I just had the same propblem, minus the permission issues. I had a feature selected within the feature class that I was trying to export and that was the reason for my error. Once I cleared my selection, the export to shapefile worked.


In addition to all of the above, I found that having a column formatted in excel (mine was having a number formatted to be a dollar value-- 1000 was now $1000.00) caused issue with exporting. Going into the original spreadsheet and formatting the column to be just a generic number without a dollar sign did the trick.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.