As far as I can tell, the Google satellite imagery loaded as an xyz tile in QGIS is the same image that is used in Google Earth, but at a lower resolution. The lower image below is from QGIS using the xyz tile while the top image is from Google Earth. Both are screenshots.

enter image description here

enter image description here

I used "https://mt1.google.com/vt/lyrs=s&x={x}&y={y}&z={z}" for the xyz tile and I am using QGIS 3.8, but I also have this issue when using older versions. Is there a way to improve the xyz tile resolution?

Edit 1: the CRS for the QGIS image is WGS 84/UTM zone 17N (EPSG,32617) Edit 2: they are just simple windows snips, but do not look any different when exported using 600 DPI

  • 2
    What coordinate system is your QGIS project in? Are you in between tile scales? Commented Aug 8, 2019 at 19:40
  • 1
    Is this is a simple screen capture (e.g. Snipping tool on Windows?) If so, try Save as image... with a reasonably high dpi value (e.g. 300) and compare. Recent versions of QGIS seem to fetch higher resolution tiles (if available) for final output, but might not do so for canvas rendering.
    – Steven Kay
    Commented Aug 8, 2019 at 19:57
  • It does not make a difference how I capture/export the image in this case. The resolution is much worse from the XYZ tile. Sorry for the late reply, but this is still an issue. The CRS does not seem to have any effect either. I tried it in EPSG 4326, 32617, and 3857. Commented Oct 2, 2020 at 12:34
  • I noticed the same, that the reoslution is lower than in Google Maps itself. Still no solution for this?
    – i.i.k.
    Commented Nov 13, 2023 at 11:59

2 Answers 2


It's because QGIS restricts the maximum displayed zoom of an xyz layer by default.

In QGIS 3.34, right click the xyz tiles layer, then click on "properties" and navigate to the "Source" tab on the left. You'll see an option for "Max. Zoom Level". By default, this is set to 20, but the maximum zoom available is 22. If you increase the maximum zoom, you'll see it reflected in your displayed map.

enter image description here

  • Hi NBrown14, welcome to GIS SE. Great answer. Hope to see you again around here.
    – Babel
    Commented Jan 9 at 20:53

I have a great resolution inserting a xml layer for Google Earth as indicated on this webpage: https://felix.rohrba.ch/en/2016/awesome-basemap-layer-for-your-qgis-project/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.