1

Trying to map cotton fields of CA using data from this site https://nassgeodata.gmu.edu/CropScape/

Can not get my map to have a topographic underlayer without the other crops showing up as well other than cotton. How would I fill my layer with topology but only show cotton fields and not other crops??

enter image description here

enter image description here

1

What is shown on your first picture is not topography (or topology), it's cropland cover (including shrubland, forest etc.). When you only display cotton, the rest will be blank. You need a second layer with topography information, or what ever you want to "fill" your map with and put this layer behind your layer. In the transparency settings of your layer you can set everything but cotton to 100% transparency (or no data) so you can see the layer in the background.

Edit: As pointed out by user csk, there is a section in the QGIS manual about raster transparency: https://docs.qgis.org/3.4/en/docs/training_manual/rasters/changing_symbology.html#fa-changing-the-transparency

  • This is a good answer. You could make it even better by including a link to the section of the manual about setting raster values to nodata or transparent. I don't think it would be obvious how to do that (or even where to look it up) to a new QGIS user. – csk Aug 9 at 14:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.