0

I'm working with some Ordnance Survey data, specifically the VectorMap Local (in GML format, October 2018) set and attempting to style the layers using the very handy OS provided stylesheets (here: OS Github Repo link). All the layers render, except for those for which the stylesheets are using rule-based symbology, so this seems to be the source of the trouble. This means that Text.qml, VectorMapPoint.qml, Line.qml all work fine (see repo link above) and that Area.qml, RailCLine.qml, RoadCLine.qml fail to render anything, just white blank canvas.

I've ruled out the obvious candidates. The rule works, or at least testing the rule indicates that it is finding the right features:

screenshot

I've confirmed that both layer and the whole project are both using the same and right CRS (27700). There aren't any scale related issues (as the screenshot indicates, max/min aren't on very many features, including the one I'm testing). The same layer renders styling Categorised styling using the same column without any issues.

I’ve also tried working off previous commits in GitHub (master, 24 Oct 2018, 12 Feb 2018, 26 Sep 2016) and with other style sets within each of those branches (e.g. “Geopackage stylesheets”), which fails less surprisingly.

Sample data (Vector GML format in my case, os-vectormap-local-gml-sample-data.zip) can be downloaded here: enter link description here

  • Using the sample data you linked to (SX99SW) and QGIS 3.8.1, the Area.qml style works correctly. What version of QGIS are you using? Have you tried using the sample data? – Jake Aug 11 at 19:45
  • Yep / tried the sample data before posting. Actually, I’ve tried about 2 dozen 5km blocks from the VML set. I’m using 3.4 LTR. Might see about upgrading and test it in a few minutes... – Jeremy Kidwell Aug 11 at 19:46
  • Hmmm. Just confirmed problem persists for me on QGIS 3.8. Are you on a PC? I’ll see about running on another Mac... – Jeremy Kidwell Aug 11 at 21:24
  • 1
    Nope, that’s it. Works fine on another Mac. Thx for the quick check, helped me to know to push a bit further. Will post here if I isolate the source of the problem. – Jeremy Kidwell Aug 11 at 21:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.