7

I have got this message when I wanted to create a new extension. enter image description here

How can I solve this problem? I have Win10 64 bit and PostgreSQL 11.

  • 3
    Please always provide error messages as text rather than pictures. – PolyGeo Aug 11 at 11:57
  • I have a similar error also with Win10 64 bit and PostgreSQL 11. ERROR: could not load library "C:/PostgreSQL/11/lib/rtpostgis-2.5.dll": The specified module could not be found. State SQL: XX000 rtpostgis-2.5.dll is in the folder of the path that error indicates. – QGIS-Postgis user Aug 12 at 17:15
  • I have the same problem. I hope someone answers – Andrés Barbosa Aug 16 at 14:13
  • I have the same problem, let me provide some of the steps I've taken just in case it helps anyone resolve it: I've re-downloaded everything, restarted my computer, made sure I installed the latest proj4 and GDAL, installed through stackbuilder, installed through WSL apt-get. – Juan Sebastian Lozano Aug 16 at 19:10
  • Thanks, I had the same mistake and it worked for me. – user147934 Aug 17 at 10:20
6

just copy these two .dlls ("libeay32.dll" and "ssleay32.dll") from bin/postgisgui folder and paste them in bin folder.

We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed.

  • Voted up because did work for me as well. – Santeri Vesalainen Aug 21 at 8:32
  • I agree, this worked for me too on Windows 10 with PostgreSQL 9.6. – Chau Aug 23 at 6:16
  • work for me too. Postgresql 9.6 – Djana Sep 6 at 11:19
3

So this worked for me but no promises because I don't really know what I did I just followed some stuff I found else where. Now I'm on win 10 installing PostgreSQL 11.5 and postgis 2.5 (installed through the native application stack builder) all 64bit and I just did a new install of them all.

Then I followed the instructions here and copped the dll files "libeay32.dll" and "ssleay32.dll" from Postgresql>11>bin>postgisgui into the bin folder just above it. Note I did all of this without having opened up pgadmin or anything else yet, idk if that would have an effect on this. Then I opened up pgadmin 4 and went to the db I wanted to enable postgis on and instead of querying "CREATE EXTENSION postgis" (bc that didnt wana work and threw a new error) I used the gui tree on the left and went to extension>create extension and created an extension to postgis. At that point everything seemed to be working as normal, and I installed the rest of the extensions according to the normal querying style (exp "CREATE EXTENSION postgis_topology") and was able to execute all the commands to the right of this page without error. This is the full response to "SELECT postgis_full_version();"

"POSTGIS="2.5.2 r17328" [EXTENSION] PGSQL="110" GEOS="3.7.0-CAPI-1.11.0 3.7.1" SFCGAL="1.3.2" PROJ="Rel. 4.9.3, 15 August 2016" GDAL="GDAL 2.2.4, released 2018/03/19 GDAL_DATA not found" LIBXML="2.7.8" LIBJSON="0.12" LIBPROTOBUF="1.2.1" TOPOLOGY RASTER"

I did a little bit of messing around and it seems to not be throwing any errors when calling functions but I havnt tested it thoroughly.

protected by Community Aug 17 at 10:55

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.