1

I'm using QGIS 3.4 to consult the Italian cadastre maps, using the Government's WMS service available here: https://wms.cartografia.agenziaentrate.gov.it/inspire/wms/ows01.php

As the technical specifications of the WMS source explain (confirmed by GetCapabilities), the native coordinate system of their backend is EPSG:6706, so, at first, that's what I tried to use for my map. I set that as my project's CRS, enabled on-the-fly reprojection, imported some OSM tiles for visual reference (EPSG:3857).

I then created the WMS connection in QGIS and added the relevant layers. The outline of Italian provinces appeared; however, it overlayed Eritrea. Thinking I had made a mistake, I checked the CRS for the OSM tiles was correct, and it was.

So I made a test: I first checked that QGIS was making requests to the service using EPSG:6706. Right-clicked on the layer, clicked on Properties, and the WMS parameters confirmed the right CRS: crs=EPSG:6706&dpiMode=7&format=image/png&layers=province&styles&url=https://wms.cartografia.agenziaentrate.gov.it/inspire/wms/ows01.php.

I then tried to add the layer using a different CRS, just for the sake of trying. I opened the Data Source Manager, selected the WMS data source, clicked Connect, selected the same layer as before, changed the CRS to EPSG:25832 and added it. To my surprise, it worked! The outlines now overlayed the OSM tiles for Italy. Of course, the lines were a bit blurred, because my project CRS was still set to EPSG:6706 and so the WMS data was being reprojected on the fly. So I tried setting my project CRS to EPSG:25832 as well and everything looked fine.

At that point, I wrote the issue off as a mistake on the part of the WMS service, maybe they were simply returning the wrong data when making requests with EPSG:6706. That would make sense, because the issue was solved by simply switching to a different supported CRS.

Then I started fumbling around, and at some point I needed to find the GPS coordinates (i.e. EPSG:4326 coordinates) of something I was seeing on the map. So I noted the shown X,Y coordinates (in EPSG:25832, the project CRS), I opened a calculator, I set EPGS:25832 as the source CRS and EPSG:4326 as the destination CRS and I typed in the coordinates.

The coordinates didn't quite look right to me, so I pasted them in Google Maps and I ended up in... Eritrea.

I'm now convinced I'm doing something wrong; however, I simply do not know what to check. If I'm doing something wrong with the coordinates, how can the OSM tiles and the WMS outlines match perfectly, being in two completely different CRSs?

  • 3
    You have problem of swaped X in Y coordinates. – TomazicM Aug 11 at 17:00
  • @TomazicM could you elaborate on that a bit? How did that happen and what is the solution? – rrrrrrrrrrrrrrrr Aug 14 at 7:59
  • I'm not familiar with WMS servers and services, so I can't help you here. Fact is that WMS services return coordinates that have X and Y coordinates swapped. Maybe this can somehow help you: community.hexagongeospatial.com/t5/WebGIS/… – TomazicM Aug 14 at 8:29
  • @TomazicM it's more correct to say that WMS version 1.3.0 services, are axes aware, The order in which ordinates in each pair are listed shall be as defined by the Layer CRS; x corresponds to the first axis in the Layer CRS and y to the second. This order may not coincide with the Map CS axis order i, j. The bounding box coordinate values shall be in the units defined for the Layer CRS. So for both EPSG::6707, and EPSG::4326 x is latitude. – nmtoken Aug 28 at 16:56
  • @nmtoken Thanks for clarification. I'm just beginner who is answering others questions to learn. – TomazicM Aug 28 at 17:08
1

If you don't want to have to change the CRS, just tick Ignore Axis Orientation in the WMS properties and it will be displayed correctly (see screenshot below, overlapping with 3857 OSM background)

enter image description here

0

I faced the exact same problem and eventually managed to get it to work, see the answer here: https://gis.stackexchange.com/questions/288245/no-common-crs-between-two-wms-service/288470?noredirect=1#=

I have not invested time to find out exactly where the issue was originating as I needed to move forward, but these were quite the frustrating few weeks.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.