0

I made a new PostgreSQL database and am trying to add layers/tables to it in QGIS using the DBManager. And I am failing.

Here is the error message I'm getting: enter image description here

However, I can add layers to other PostgreSQL databases that previously existed. I thought it might be some problem in the way I created the new database, using pgAdmin 4, but as far as I can tell the new database is exactly the same as the others.

I tried some workarounds, including creating a new schema in an existing database and couldn't read from that new schema.

Any suggestions?

  • which data format are using to upload the data? – ziggy Aug 12 '19 at 20:48
  • 5
    Maybe PostGIS extension is not installed in this database. If not, try CREATE EXTENSION IF NOT EXISTS postgis; What does this command say?: SELECT PostGIS_full_version(); – TurboGraphxBeige Aug 12 '19 at 20:52
  • If you created a template database for PostGIS, then you could specify it in the database creation command. Please remember to include the text of the error message in the body of the Question; this makes the error legible on all devices and searchable as well. – Vince Aug 12 '19 at 21:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.