1

I've been using QGIS 2.14 pretty successfully for about two years. I do also have Arc but tend to use Q more primarily because it did run considerably faster. I then installed QGIS 3 as I noticed it had some really useful functions such as the 'multi edit tool' for the attribute table. However the difference in speed between the two versions is drastic, particularly when working with 'layer properties' or the print composer. More often than not when I open the properties menu my computer freezes and I can go and make a coffee before it's even opened and that's before I've tried to make any changes. Even moving the cursor around at that stage can lead to a 'not responding message'.

As I've not seen any other comments to this effect I can only assume I'm missing something. Perhaps a setting or something. As far as I'm aware I'm not using the program any differently than I was the previous version, but it's currently making a program that transformed the way I work into something that is almost unusable.

  • Which QGIS 3 version are you using? I think the latest as of this comment is 3.8.1. – Joseph Aug 14 at 10:32
  • which operating system are you using? – Ian Turton Aug 14 at 10:49
  • 2
    Performance questions require details on the system being used (CPU, RAM, OS, type of disk (HDD/SSD), and disk seek time (if not SSD)), the actual tasks (including data format and data location), and the time it takes to perform each task, in seconds. – Vince Aug 14 at 11:17
  • 1
    Sorry I've tried to add some more context: Qversion is 3.8.1 Windows 10 i5-5300U - CPU @ 2.3GHz 8GB RAM OS 10586.1540 Going through a network drive but this wasn't an issue previously. I can't directly access the local drive but the machine that Q is installed on is an hp-elitebook-840 if that helps? – Catch Aug 14 at 11:57
  • 1
    Main issue is when editing properties of a .shp layer the menu can take upwards of 180 seconds just to open and my computer is frozen while it's doing it and it's similar for print composer. It doesn't seem to matter the size of the layer (could have 6000 attributes could have 10). Opening attribute table is has a similar effect but we're only talking 10 seconds or so. Simple algorithms like clipping and selecting by location seem to be unaffected if not slightly quicker. Thanks again. T – Catch Aug 14 at 12:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.