0

I'm encountering an issue with zonal statistics in which my output table contains less zones than my input (the output contains roughly 1/3 of the input zones). It is a large data set with about 65,000 zones (vector) and a raster grid of population density with a cell size of 5 meters. There is a lot of overlapping among the zones, but I am using Zonal Statistics as Table 2, which should be able to handle that. From other users' accounts of this issue, I've come to understand that zones are excluded in the output table if they do not overlap any of the cell centers in the raster grid. However, in my data set, all zones are >800 meters in diameter and the cell size of the raster grid is 5 meters, so I don't think cell size can be the root of the issue here. I also have made sure in the environment settings to set the cell size to 5 meters, set the snap raster as input raster grid, and to set an appropriate boundary and mask. I'm using ArcMap Desktop Version 10.5.

Does anyone know what could be causing this issue?

  • Make sure you explode all your polygons before calculating the statistics, otherwise some will be treated as a single zone – haresfur Aug 15 at 2:42
  • Alternatively create non-overlapping subsets and use normal zonal statistics. – FelixIP Aug 15 at 6:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.