1

I want to create Attribute-based polygon with SLD but when I use Persian or Arabic filter It's not working. This is my sld:

Attribute-based polygon SLD Cook Book: Attribute-based polygon

    <Rule>
      <Name>rule1</Name>
      <Title>rule1</Title>

      <ogc:Filter>
        <ogc:PropertyIsEqualTo>
          <ogc:PropertyName>test</ogc:PropertyName>
          <ogc:Literal>'مقدار ب'</ogc:Literal>
        </ogc:PropertyIsEqualTo>
      </ogc:Filter>

      <PolygonSymbolizer>
        <Fill>
          <CssParameter name="fill">#66FF66</CssParameter>
        </Fill>
      </PolygonSymbolizer>
    </Rule>


    <Rule>
      <Name>rule2</Name>
      <Title>rule2</Title>

      <ogc:Filter>
        <ogc:PropertyIsEqualTo>
          <ogc:PropertyName>test</ogc:PropertyName>
          <ogc:Literal>'مقدار الف'</ogc:Literal>
        </ogc:PropertyIsEqualTo>
      </ogc:Filter>

      <PolygonSymbolizer>
        <Fill>
          <CssParameter name="fill">#cc5577</CssParameter>
        </Fill>
      </PolygonSymbolizer>
    </Rule>



  </FeatureTypeStyle>
</UserStyle>

Can anyone help me?

  • you don't need the ' marks around the literal value unless they are in the data like that – Ian Turton Aug 20 at 8:48
  • I try without " ' " but not working – ch65 Aug 20 at 8:54
  • can you add a small sample data set? – Ian Turton Aug 20 at 8:55
  • Thank you for answer my data place in sql server – ch65 Aug 20 at 8:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.