7

I'm working on Ubuntu 12.04 server; I noticed this when I installed additional support for ECW format into the GDAL 1.9.1 which worked OK. Then I tried to add ECW files to QGIS but it said they still weren't supported. I checked Help->About and to my surprise the GDAL version that QGIS was using was 1.7.3; no wonder they didn't work.

Through trial and error I removed QGIS then I reinstalled it via synaptic installer and also forcefully disabled the libgdal 1.7 as a dependency. Then QGIS loaded the version of GDAL I intended for QGIS from the beginning. But this seems like an overkill to do and I don't feel like I'm having much control here

Is there a better way to for example:

  • check which dependencies exist and don't need installing, or
  • is there a way, a config file or something to tell QGIS which library version you want it to use

The packages for 12.04 seem to be quite old and have old dependencies installed with them. This same issue arises with qgis-mapserver for which I have no way of telling which version of GDAL it is using, but my guess is the old one, because ECW imagery doesn't work while other does.

9

If I had to guess you are not using the most uptodate QGIS. please follow this link, to ubuntuGIS repository and they have instructions on how to include them in your software sources.

I believe this is the recommended method of using OSGeo projects in Ubuntu https://launchpad.net/~ubuntugis/+archive/ppa hope this helps :)

ps: you can also just cmdline:

sudo add-apt-repository http://ppa.launchpad.net/ubuntugis/ppa/ubuntu

PSS: this is similar question: How to install stable GDAL on Ubuntu 11.10?

EDIT: found another link: Installing gdal 1.9.0 on linux ubuntu server 10.04?

  • 3
    This is the right suggestion, use always the ubuntugis repo, because it has all the packages and the latest version of them. In the standard Ubuntu repos for example there is a not recent version of GDAL. The QGIS project maintain a repo with qgis compiled against the packages available in the standard Ubuntu repositories, so sometimes it is easy to make confusion. – Giovanni Manghi Sep 11 '12 at 21:20
  • 3
    I would suggest ubuntugis-unstable which contains more recent releases of gdal qgis and postgis $ sudo add-apt-repository ppa:ubuntugis/ubuntugis-unstable – nickves Sep 11 '12 at 22:15
  • Okay.... i ll build a virtual machine from scratch and start over, because im quite sure i actually used this repository for my qgis installation at some point. Thanks for the tips anyway – U2ros Sep 12 '12 at 8:04
  • Indeed you 2 are right. The installation listed on official page install outdated libraries with qgis(and i recommended this to some guy just a few days ago :D) Btw, does anyone know why is there a library called libgdal-1.7.0 listed as a dependancy. This probably isnt gdal itself is it? – U2ros Sep 12 '12 at 9:30
0

QGIS has official repositories for various Linux platforms. Get it here. 12.04 (LTS) precise supported.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.