2

I need to georeference an image. I had QGIS 3.2 installed. When I clicked on "Plugins -> Manage and Install Plugins" QGIS froze. So, I tried installing 3.8 and the same things happened. Tried 3.4, same result. Tried uninstalling old versions, restarted computer...same result. There is an old bug report referencing this problem: https://issues.qgis.org/issues/19526

Is there a known solution to this freezing, or alternatively, a workaround that will allow me to georeference in QGIS without needing to use "Manage and Install Plugins"?

For instance, could I manually install a georeferencing plugin?

2

The georeferencer plugin is a core plugin, so you don't need to install it. You just need to enable it, which is much easier. If you need access to other (non-core) plugins, see this questions for instructions to install a plugin without using the Plugin Manager: How to install a QGIS plugin when offline?

How to enable an already installed plugin without opening the Plugin Manager:

  1. Find your QGIS user profile file. On Windows, it should be in this folder (substitute your username):

    C:\Users\username\AppData\Roaming\QGIS\QGIS3\profiles\default\QGIS

    See this question for more information if you have trouble finding your user profile: Save and load user profiles in QGIS

  2. Open the file called QGIS3.ini. It should open in a text editor, eg Notepad.

  3. Search for "georefplugin". It should be in the [plugins] section, near the end of the file.

    enter image description here

Make sure QGIS is closed before making any changes. (I don't actually know what happens if QGIS is open when you make changes to the active user profile file. Maybe nothing, or maybe QGIS crashes, or maybe something worse. I chose to remain ignorant.)

  1. Change georefplugin=false to georefplugin=true. Save and close the file.

  2. Open QGIS. The georeferencer plugin should be enabled.

Note: I actually did this on my computer, and it worked as described. I don't have any trouble opening the plugin manager, so I can't promise that this will solve your issue. Please let me know whether it works for you.

Update:

This method also worked for Cody. Their experience differed slightly from mine:

  1. Windows hid the directory "AppData..." when they tried to navigate to it from the file explorer. They accessed it by searching the C:\ drive.
  2. The "georefplugin=..." line was not present in their .ini file. They added it to the file in the position I indicated. That worked to enable the georeferencer plugin.
  • Your solution worked perfectly. A couple of notes: 1) Windows hid the directory "AppData..." from me when I tried to navigate to it from the file explorer. I did a search on my C:\ drive in order to access it. 2) The "georefplugin=..." line was not present in my .ini file. So, I added it to the file in the position that you indicated. Thank you! – Cody Aug 22 at 20:40
  • Excellent notes. I added them into my answer. I wonder if the missing "georefplugin=..." line is a symptom of the same issue that causes QGIS to crash when you try to open the plugin manager. – csk Aug 22 at 20:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.