I'm working on QGIS 3.2.1 and when I tried to edit a layer using advanced digitizing tool and set the layer in the editing mode, the split features is the only active icon and the rest is not active as in the below screen. How can I change this?

enter image description here

  • 1
    What coordinate system and data format are you using?
    – ahmadhanb
    Aug 26 '19 at 7:18
  • Kml files, I should work on EPSG:32636 but when I set the layer on this CRS, it move the layer to another part of the world. Please note I changed my laptop and I loaded the project once set up Qgis on the new laptop
    – Emamahm
    Aug 26 '19 at 7:27
  • 1
    What happens if you open your kml, what coordinate system is shown? It should be WGS84 (EPSG:4326). Please try to save the kml to a shapefile or geopackage and change the coordinate system (means transform it to) EPSG:32636 within that step. I don't know i this can help with editing fuinctions, but it should help editing in the correct coordinate system and with a more stable data format. Aug 26 '19 at 9:24
  • 1
    It works when I inserted the layer as a shapefile. Thanks for your support
    – Emamahm
    Aug 26 '19 at 13:35

Digitizing tools does not work with kml files.

Please save your kml to shapefile: Save as/Export> Format = ESRI Shapefile

Also, the other tools, such as to change polygons, only work if you have polygons on your layer.

  • Can't confirm that "Digitizing tools does not work with kml files". I have points inside a kml, and the advanced editing tools are not completely grayed out, and i can edit the data... My QGIS-Version is 3.4.10 Aug 26 '19 at 9:50
  • 1
    I worked with it before using the same Kml files. Do you know other way to insert ddmmss coordinates into qgis
    – Emamahm
    Aug 26 '19 at 12:05
  • Yes, csv works also. Qgis uses GDAL/OGR for data access. So there are multiple possibilities. See here Aug 26 '19 at 14:48

You need to "activate" first, by clicking the yellow pencil (toggle editing): enter image description here

  • 1
    The OP's screenshot shows that the yellow pencil button is selected...
    – csk
    Aug 26 '19 at 16:06
  • oh, thanks for the hint, I have "overseen" it.
    – Kurt
    Aug 26 '19 at 20:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.