1

I'm using QGIS 2.8.9 Wein and the plug-in MOLUSCE(ver. 3. 0. 13). Now I'm trying to create a change map, but get the following error.

Traceback (most recent call last):
  File "C:/Users/.../.qgis2/python/plugins\molusce\moluscedialog.py", line 479, in changeMapDone
    self.inputs["changeMap"].save(self.inputs["changeMapName"])
AttributeError: 'NoneType' object has no attribute 'save'


Python version:
2.7.5 (default, May 15 2013, 22:44:16) [MSC v.1500 64 bit (AMD64)]

I'm new to QGIS and not familiar with Python.

So I wonder that "NoneType" something means that the preprocessing was wrong... but not sure.

EDIT: Updated to QGIS 2.18, but the same issue persists.

4
  • If you just started using QGIS, why install such an old version? MOLUSCE 3.0.13 is compatible with QGIS 2.18.
    – csk
    Commented Aug 26, 2019 at 16:04
  • I misunderstood that this is the latest QGIS 2.XX for some reason... I've installed 2.18. Thanks!
    – kei
    Commented Aug 27, 2019 at 13:42
  • Did that fix the problem, or does it persist even with version 2.18?
    – csk
    Commented Aug 27, 2019 at 17:23
  • I tried the process in order and it still returns the same error.
    – kei
    Commented Aug 28, 2019 at 10:59

1 Answer 1

1

I found the way of solving the issue! I'd continued searching for it, and reached the following github comment:

https://github.com/nextgis/molusce/issues/9#issuecomment-307839416

The rasters have 3 to 4-digit codes used to classify land use types. I used r.reclass to change the codes into smaller numbers and I could make a change map.

Thanks.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.