0

I am trying to do a RBR (Relative Burn Ratio) and for this, I am using two Sentinel 2 L2A images (before and after the fire). The native CRS of the data is EPSG:32634 - WGS 84 / UTM zone 34N - Projected .

Since SNAP can work with archived Sentinel 2 imagery, I use the data as it was downloaded from Open Access Hub.

After I do the processing and the results are achieved (one RBR raster), I am exporting it in GeoTIFF format and trying to open in in QGIS. In QGIS, the layer does not line up with the basemap. So, I try to reproject the layer in SNAP and export it again... same problem.

For the workflow, I'm using QGIS 3.4 LTR but this does not matter that much, since I've also tried to display the results in ArcGIS 10.2.2 also. The basemap is Google Satellite with the CRS EPSG:3857 - WGS 84 / Pseudo-Mercator - Projected.

Reprojection didn't work(neither in ArcGIS, QGIS or SNAP) nor changing the CRS until the layer lined up with the basemap.

The discrepancy between the result and the basemap can be seen below.

enter image description here

  • If the result layer doesn't line up with the basemap, it's probably not set to its native CRS. Change the CRS in the layer properties. Try different CRS's until you find the one that makes it line up with the basemap. Only when the layer has its native CRS can you re-project it into the CRS you want. – csk Aug 26 at 16:43
  • I did. I have tried with the native CRS of the result layer but still the same problem. I am wondering if it could have something with the processing. At one point, I am using a graph o automatize some steps (resampling-subset-band math-bandmerge). After this process is done, if I try to open a band in QGIS, the band doesn't line up with the basemap. I have tried with other imagery and it's the same problem so, I guess I'm doing something wrong maybe, but I don't know what exactly... – onemindwork Aug 26 at 17:03
  • Please update your question with the CRS and extent of the original data and post-processing. What CRS is the basemap in? – mkennedy Aug 26 at 17:06
  • Question updated. – onemindwork Aug 26 at 17:17
  • "Does not line up with the basemap" - 1. What basemap are you using/which CRS is the basemap in? 2. Please provide a screenshot which shows how large the discrepancy is. 3. Which version of QGIS are you working with? – Erik Aug 27 at 7:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.