Trying to create a grid from a shapefile (using canvas extent), but when I click 'run', it tells me it is 'Processing algorithm...' and then hangs on this indefinitely without progressing (with my Mac often telling me to Force Quit QGIS as the programme is not responding). EPSG is 4277 - OSGB 1936.

I've tried this on QGIS 3.4.1 and 2.18.0 and the same is happening on both.

Am I doing something wrong?

I'm new to using QGIS (following someone else's instruction sheet) and this is the extent of the instructions I have been given.

enter image description here

What should I be selecting for the different options in the 'create grid' interface?

This is what I've got so far. I know those warning triangles shouldn't be there, but I haven't been able to work out how to get rid of them. Increasing the degrees figure doesn't seem to change anything.

enter image description here

  • Please give more detail like EPSG of your shapefile (and of your project and desired output if they are different) and the exact setting you use for the grid creation – J.R Aug 28 '19 at 15:26
  • EPSG is 4277 - OSGB 1936. What do you mean by exact setting? (sorry, I'm a bit of a QGIS noob. Trying to follow someone else's instructions, but not getting on very well!). – gariochquine Aug 28 '19 at 15:29
  • Please add precision by editing your question, not in comment. By setting I mean what parameters did you input in the "Create grid" tool (a screenshot would be nice), also your CRS is in degree the tool should give you warning and prompt you to re-project – J.R Aug 28 '19 at 16:03
  • Thanks, J.R. I've added some more info. – gariochquine Aug 28 '19 at 16:09

There is a problem in your extend and/or your Shapefile.

From https://spatialreference.org/ref/epsg/4277/ EPSG 4277 has

WGS84 Bounds: -7.5600, 49.9600, 1.7800, 60.8400

Projected Bounds:-7.5593, 49.9593, 1.7824, 60.8407

the grid extend you set didn't fit in that (it more look like a prejected extentd)

If you get the extent from a shapefile this shapefile is not in 4277, if you get the extend from the canva extend your project is not set to 4277.

try to get everything in the same EPSG and try again (by reprojecting your shapefile if needed and changing the CRS of your project in Project>Properties...>CRS tab)

| improve this answer | |
  • almost certainly actually in 27700 (OSGB) - in metres – Ian Turton Aug 29 '19 at 6:47

The extent setting is the problem. The extent seems to be in projected CRS, not in degrees. The extent xmin is 212862 and xmax is 455229, so with the spacing of 1, you are asking QGIS to create ~242367 vertical gridlines, which obviously takes a long times and hangs your program.

There are multiple options of setting the extent through the interface, choose the one that gives you extent in degrees.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.