I'm unable to save any shapefile edits (polygon, point, line) using QGIS. I have tried multiple versions including 3.4 and 3.8. I have tried removing all installed plugins. I have tried new projects, creating new shapefiles, nothing is fixing the issue. It was working last week without issue but as of this week has not worked.

  • Does the .shp show any locks on the file when you view the files within their parent folder? – scabecks Sep 2 '19 at 0:56
  • Thanks for the reply, there are no locks within the parent folders. – Conor Sep 2 '19 at 1:00
  • Just out of interest, if you make a duplicate of the file in another format (i.e., export it to a geopackage), does the same thing occur? – scabecks Sep 2 '19 at 1:03
  • Yes. Even if I create a completely new shapefile and try to create geometry it does not allow me to save. – Conor Sep 2 '19 at 1:07
  • Sorry, I misread your initial question (no coffee yet) and edited my previous comment. If you try another file format such as a geopackage does it change anything? – scabecks Sep 2 '19 at 1:14

After you press the pencil button you can edit your shapefile layer. After editing you just press it again and if you made any edits it should ask you to save the changes. You have to select the layer in the layers panel to be able to press the pencil.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.