2

I have a problem with getting an Interpolation with the Interpolation Tool on QGIS 3.8.1-Zanzibar.

I just performed an IDW interpolation via the QGIS toolbox, with values from a layer that are 18 different recording stations in an area. The values I added manually to the attribute table (see field types in picture 2) and I want the extent of the Interpolation to be in the borders of that investigated area (red borders in picture 1).

The points of the recording stations

picture_2

After computing, it creates a raster layer, but I can not see anything and the min and max values are the same (the mean of the original values), see picture below.

picture_3

The same was asked in Performing IDW interpolation in QGIS?, but not answered how to solve it in the actual version of QGIS.

Has somebody an idea what could be the problem and how to solve it?

It worked with a GDAL raster analysis to create an IDW with nearest neighbour search, but there I just could set the extend overall points so I received a rectangle and not until the red borders.

It isn't either like in this post, because I use EPSG:25832 which is in meters and with 0,1 Pixel size X I reach 4490 rows and 13364 columns (see picture 4)

enter image description here

Here also the attribute Table

enter image description here

4
  • 1
    Which field have been used for interpolation?
    – ahmadhanb
    Sep 2, 2019 at 7:43
  • I tried "MidFreqCover", "ClusterCount" and another field I already deleted, which I created artificially with just different integer numbers from 1 to 40.
    – Jan
    Sep 2, 2019 at 7:54
  • Possible duplicate of IDW in QGIS 3.8
    – JGH
    Sep 2, 2019 at 9:51
  • Not completely, I have EPSG 25832 and now tried to use smaller Pixel size. It needed like 4 hours to calculate with pixel size 0,01 and crashed at the end. And with 0,05 it had the same result like described, nothing visible and the min and max is the same.
    – Jan
    Sep 2, 2019 at 22:17

1 Answer 1

2

The final problem were different CRS. The points were in 4326 and my Project layer in 25832. I changed everything to the same CRS and it worked.

Thanks for the help.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.