3

Using 3.8.2 Zanzibar 64 bits I am mystified by being able to load the attributes of an approx 1e6 features shapefile (even if it takes a bit of time), but waiting forever to show the attributes of the selected (sub)set of around 25. Compu is ryzen 2700x with 32 GB memory. IMO this should be as basic as it gets. What happens here, anyone?

2
  • Did you filer the attributes using the Provider Feature Filter in Layer Properties > Source or via the attribute table?
    – Joseph
    Sep 3, 2019 at 9:42
  • No filter, I selected on the map drawing a mouse rectangle
    – Jan
    Sep 3, 2019 at 16:26

1 Answer 1

5

QGIS has a longstanding issue with slow attribute table loading for large layers. The entire attribute table pre-loads before you can see attributes for a subset of your features. It's a problem. The devs are working on it. Apparently it's more difficult to fix than you might imagine; you can read about it here and here.

In the meantime, you can work around the issue in various ways.

  • Filter the layer before opening the attribute table.
  • Create a virtual layer that only contains the selected features of the original layer.
  • Create a temporary scratch layer with exactly the same attribute table setup as the original. Copy and paste features from the original layer into the temporary layer. View their attributes in the temporary layer attribute table.
  • Use the Identify tool to access the attributes instead of the attribute table. Note that you can click and drag to "identify" multiple features at once.
  • The DB manager preview might be helpful, per this comment on github.

I'm sure there are other workarounds. Everyone, please feel free to chime in if you have other suggestions.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.