1

I have followed tutorial for labelling from multiple columns, e.g. name and also grade. Looks correct in expression but nothing shows in output preview. Any idea where I am going wrong?

enter image description here

closed as unclear what you're asking by LaughU, Taras, Vince, Fran Raga, Oto Kaláb Sep 5 at 17:45

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 2
    Please add more detail (where did you put this expression, did it work with a single column, what are your label setting....) – J.R Sep 5 at 9:08
  • 2
    Better look in the final map ... i think the preview is usually based on a given row (first one ?) and is eventually empty ... at least syntax looks ok ... – snaileater Sep 5 at 9:09
  • Hi, yes works with single column, eg "Name" and it shows up in preview. – Rebecca Sep 5 at 9:13
  • 2
    You might also try the function concat as an alternative: concat ("Name", '\n', "Grade"). If it doesn't work: try skipping '\n' - does it work with just "Name" and "Grade"? If you use singe colum "Grade", then what is your output? – babel Sep 5 at 9:33
  • 1
    Have solved the issue, upon checking the attribute table there was a null value in grade. Doh! Have added value and now shows both name and grade. Not all entities have a grade so those that don't do not show at all (even the name) but those have a grade now show both name and grade. Thanks everyone, got there. – Rebecca Sep 5 at 9:48