0

I have a series of plot points in the UK. All I want to do is overlay a simplified map of the UK, ideally just an outline.

I obtained some simplified colour maps from the OS website, added as a layer, but I can’t see the points beneath. I can’t merge them. Perhaps the map has to be a vector rather than what I have , a raster.


I tried altering the layer order but no change. I am afraid.

If I "Zoom to layer" then it will show the layer of choice. But I can't see both together even if I alter opacity.

I think I am loading the map raster wrong, I am just loading it from the Browser and selecting the file directly. Perhaps it needs a bit more than that.

  • 7
    Just put the points on top of the raster map by ordering them in the layer window. – Erik Sep 9 at 10:07
  • in that case the projection of your points or raster is wrong – Ian Turton Sep 10 at 7:21
  • Thanks Ian. The projection of the points can't be wrong or they wouldn't show in any meaning pattern would they? (They do sort of fall within a UK shape,roughly!). They are just CSV GPS Coordinates. Not sure what to do if the "projection of the raster" is wrong. – LostInSpace Sep 10 at 9:15
1

Based on the discussion in the comments, it now seems that the issue is one of projection. When you load geospatial data into QGIS (or any GIS program), sometimes QGIS will automatically detect the layer's projection, or sometimes you need to tell QGIS what projection that layer is in. In either case, if you chose the wrong projection or QGIS did, the layer will show up in the wrong part of the world. The elements within that layer (eg, your points layer) will be arranged correctly with respect to each other, although the distances may also be wrong.

Figure out what projection each of your layers is supposed to be in, and re-load the layers in their correct projection.

  • The points layer, as you mentioned, has GPS coordinates, which I assume are latitude and longitude. The normal projection for latitude and longitude coordinates is EPSG:4326. Re-load the CSV file using the "add delimited text" option (in the Layers menu). Choose EPSG:4326 for the CRS (CRS is short for coordinate reference system, which means approximately the same thing as projection). QGIS will show you a preview of your data. Make sure the columns are loaded correctly. The coordinate order for EPSG:4326 is longitude/latitude (not lat/long), so choose the longitude for the X coordinate field and latitude for the Y coordinate field.

  • The raster layer comes from the OS website. Go back the page where you downloaded that file, and look for information about what projection (or CRS or SRS) the layer is in. It's probably in a section called "metadata" or "info" or something like that. If they're nice, they gave you the EPSG code for that CRS. If not, you might have to piece together several bits of information to figure out the correct CRS. Look for words like projection, coordinate, and datum. If you have trouble, please provide a direct link to the page where you downloaded this layer.

  • The metadata for the GADM layer I suggested in my other answer says:

    The coordinate reference system is longitude/latitude and the WGS84 datum.

    That's the same as the points layer, EPSG:4326. Since the layer is already stored with its coordinates in the correct order (long/lat instead of lat/long) you don't have to worry about coordinate order. Just re-load that layer and choose EPSG:4326 as its CRS. If you don't get the option to choose a CRS when loading the layer, open the layer properties (right click on the layer name in the layer panel) and change the CRS there.

  • CSk, you got it! There were 3 variants of EPSG:4326. I tried another and everything just magically fell into place. Thank you so much for your help. – LostInSpace Sep 11 at 2:42
3

I am assuming you are new to QGIS.

  1. Firstly you need to make sure you have your 'Layers Window' open. Go to View > Panels > Layers to open it if not.
  2. Load your layers (shape files and rasters) by dragging it into QGIS.
  3. Order your layers in the 'Layers Window' depending on which layer do you want to see above which other layer.
  4. If there is a layer and you want to make it a bit transparent and see the immediate layer below it, you can adjust its Opacity. For that double click on the layer, click on Opacity and adjust it as required.
0

Your raster image is covering up your point layer. The simple solution is to rearrange the layers in the layer panel. Move the point layer enter image description here above the raster layer enter image description here.

enter image description here

enter image description here


If you prefer to have a simple country boundary line instead of a raster image, you can obtain a country boundary as a vector from here. Choose your country from the dropdown list and download the level-0 KMZ file.

Import it into QGIS.

Open the Symbology panel and change the symbol layer type from "simple fill" to "outline: simple line"

enter image description here

  • Thanks CSk. The map link you gave is excellent. But same result. Not getting the points on the map, getting one or the other but not both. When I "import" the I am using the Browse function and just navigating to the file. Perhaps this is not the correct procedure. – LostInSpace Sep 10 at 9:13
0

It's worth checking your layer order panel (different to the layers panel) by right clicking anywhere on your toolbar or by going View>Panels>Layer Order Panel. Once open, make sure the option 'control rendering order' is unchecked.

enter image description here enter image description here

  • Thanks James, good to know. It was unchecked anyway. – LostInSpace Sep 11 at 2:38
  • Have you resolved the issue? – James B Sep 11 at 9:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.