No crash in this case, but I made the mistake of toggling to fullscreen mode on my netbook running Ubuntu 12.04. It's now impossible to escape this "No Menus" view, and it seems to have disabled the popout unity launcher as well. Steps I've already taken:

  • Alt-Tab to move to a different program, then back - QGIS remains in fullscreen
  • Alt-V, Ctrl-F and F11 get no response
  • I've unistalled QGIS, deleted the /.qgis/ profile data folder, and reinstalled. Still launches fullscreen

To add to the weirdness, it now launches - still in fullscreen - into a different workspace than the active one.

I realize this has the sound of a Unity problem, but it's just this program that has a malfunctioning UI.

Thanks to all the crew; this in no way changes my opinion of QGIS as an essential tool.

  • 2
    I am experiencing exactly the same problem with Ubuntu 12.04 and QGIS 1.8 It happened just after I clicked the fullscreen icon (the little square in the windows navigation pane) and I am unable to get QGIS started normally again. Rather it flickers horribly and cannot respond normally to mouse clicks. Ctrl-F does not fix the problem Rebooting does not fix the problem Will try to replace Ubuntu with Linux Mint 13 and let you know.
    – user10675
    Oct 3, 2012 at 2:44

4 Answers 4


I'm now convinced this is a unity/desktop switcher bug. The QGIS window appears in one desktop but the menu header appears in a separate desktop. I'm closing this as a lost cause, with apologies to anyone who spent time on this as a QGIS issue.


Using the same version of Ubuntu and QGIS (via Oracle Virtual Box)

If you go into full screen mode then hover the cursor over the top middle of QGIS and wait a few milliseconds the full menu should appear then you can go to View>Toggle Full Screen Mode, (ctrl+f) seems to work to on my version.

enter image description here

  • I had already tried that with no luck. No menu appears after any length of hover. Sep 17, 2012 at 0:28

I experienced the exact same problem with Ubuntu 12.04 and QGIS 1.8. Replacing Ubuntu 12.04 with Mint 13 solved this problem.


I had the same problem. Recovered with Alt and right click on the top left corner, and send qgis to another work area. So you can see the hidden menu, and work normally. last, you need to re-assign the "toggle fullscreen mode" because is assigned to another function. (press f2, config shortcuts)

Not the answer you're looking for? Browse other questions tagged or ask your own question.