1

I'm working with Quantum GIS 1.8 Desktop on Ubuntu 11.10. Two days ago the program crashed while I was working with some WMS layers and then it hasn't been working any more. When I open Quantum GIS Desktop the program starts, the logo appears but nothing more happens and then Ubuntu suddenly quit the application.

I have tried several times both to remove Quantum GIS and to reinstall it, but the problem remains.

Could you help me?

  • 1
    did you try to do $ sudo apt-get purge qgis ? and then re-install? – nickves Sep 14 '12 at 12:55
  • re-installing is the quickest and best method. If you used a Virtual Box you can take snapshots - I use this method a lot when testing. – Mapperz Sep 14 '12 at 13:18
  • The first command ($ sudo apt-get purge qgis) doesn't work. – user8780 Sep 14 '12 at 14:41
  • I have already tried to uninstall and re-install QGIS several times, but this approach doesn't seem to solve the problem. – user8780 Sep 14 '12 at 14:42
1

You need to remove the dependencies as well. So after

$sudo apt-get remove qgis

run

$sudo apt-get autoremove

I hope it works.

  • There are two errors: – user8780 Sep 14 '12 at 14:22
  • Could you please post the errors on your original post? – R.K. Sep 14 '12 at 14:26
  • I'm haveing some problems with /var/lib/dpkg/lock – user8780 Sep 14 '12 at 14:32
  • I'm having some problems with /var/lib/dpkg/lock – user8780 Sep 14 '12 at 14:32
  • You could solve that by deleting the lock file. rm /var/lib/dpkg/lock – R.K. Sep 14 '12 at 14:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.