2

My area lies between E 92.25-92.50 and N 24.50-24.75. When I tried to draw the coordinates on QGIS 3.8 map composer, it showed the co ordinates as E 8.00-E 24.000 and N 0.000-16.000. I used the correct coordinates and projections but the problem still persists. I took "Decimal with suffix" and used "cm" or "mm" as the interval units. But that should not be a problem because the layer and the project are in the same projections. Please show with illustration how to fix this problem. QGIS grid outines are attached.

enter image description here

  • 1
    Yeah, no, there's nothing attached. – Erik Sep 16 at 9:05
  • I tried to attach but there is some error with this. Trying to do it again – A Salim Khan Sep 16 at 9:14
  • Well, your map doesn't show anything, have you made sure you zoomed in on your canvas content? – Erik Sep 16 at 9:19
  • Map does have content, I removed the content as it can not be shown here. It is an ongoing work.The issue is with the grid not with map content. – A Salim Khan Sep 16 at 9:25
  • Educated guess: You try to force the map grid into a CRS different from your project's CRS. – Erik Sep 16 at 9:34
1

enter image description here

Disclaimer: I worked with QGIS 3.4, since this is the current LTR.

Anyway, I used your points, which are in EPSG 4326, my project was in the same CRS, I set the grid to it also. The display was only correct, when I chose mapunits for the interval and set it to a fitting low value.

  • Thank you so much for your kind help. I think the error on my part was taking "mm" "cm" in place of map units.Thank you once again for this. – A Salim Khan Sep 17 at 16:34
  • I tried and it worked well. I was struggling with this issue for the last two weeks. God bless you for this Kind help. Thanks a lot. – A Salim Khan Sep 17 at 16:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.