0

I have a feature layer called map in AGOL. I want to change the symbology, so I open arcgis Pro and I open this map and overwrite it with new symbols.

I see that the feature layer in AGOL is updated correctly. Only the views of this feature layers aren't updated at all.

Why is this and how can I make sure the views are also updated as well ?

PS: The legend is also not updated of the view layer.

enter image description here Hosted feature layer (above)

View of hosted feature layer (below)

enter image description here

2

Making this change will not propagate down to views. The view could have its own symbology set and the parent layer can be changed independent of it. You will have to make the change at the view level.

  • 1
    Aah okay! I read somewhere in another post that if you want to change the symbols for, let's say, 10 views of 1 hosted feature layer you need to use a script. Or make the changes with your hand. So besides using a script or changing each individual layer there is no way? – jamlego Sep 17 at 11:53
  • 1
    Correct, you have to to do it either manually or script it. – Russ Roberts Sep 17 at 12:38
0

How did you save the revised symbology settings in Pro? You may be better off editing from the AGOL Map Viewer, since the changes you make there will be automatically saved to the feature layer upon saving.
- Go to your Content section - Click on the feature layer - Select Open In Map Viewer in the right hand menu - Select "Change Style" and make all the changes you need - Click the Done button - Select Save from the top menu and save.

  • If I do it in AGOL or Arcgis Pro. It doesn't matter that much. The real issue is that I can have 20 views of 1 hosted feature layer. So to change the symbols of all the views will be long task – jamlego Sep 17 at 11:49
  • Are you theming the symbols based on one of the data fields, or are you using a consistent symbol for all of the rows? Either way, it shouldn't take more than a minute or two to make the adjustment in the AGOL map viewer. Here are some instructions: doc.arcgis.com/en/arcgis-online/create-maps/change-style.htm The reason I asked where you were making the adjustment is that Pro is desktop software, and it's possible that you only made the change in a way that would be reflected locally on your desktop without saving the change to the hosted feature layer in AGOL. – Brian Sep 17 at 17:11
  • I use one consistent symbol. I use a custom symbol that isn't available in AGOL. So normally I would use Pro then to make the symbol changes. I tested it just now, and when I make a symbol change in Arcgis Pro, the hosted feature layer in AGOL also changes it's symbol to the one in Pro. Only the views aren't changing – jamlego Sep 18 at 7:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.