3

I have installed OSGeo4W following this: Installing QGIS with FileGDB?

Now I have QGIS Desktop 3.8.3 and gdal-filegdb 2.4.1-1 installed on windows 10.

I open directory that include the following file extensions: gdbindexes, gdbtable, gdbtablx, spx, atx, freelist , selecting ESRI FileGDB as described here too Installing File Geodatabase (*.gdb) support in QGIS?

Error "Invalid data source" is displayed.

How to open these files in QGIS?

closed as off-topic by user2856, Vince, Fran Raga, MrXsquared, J.R Sep 19 at 11:50

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This problem cannot or can no longer be reproduced. Changes to the system or to the asker's circumstances may have rendered the question obsolete, or the question does not include a procedure to enable potential answerers to reproduce the same symptoms. Such questions are off-topic as they are unlikely to help future readers, but editing them to include more details can lead to re-opening." – user2856, Vince, Fran Raga, MrXsquared, J.R
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 4
    [Windows 10] Layer>Add Layer>Add Vector Layer>Source Type 'Directory' OpenFileDB then go to the folder xxx.gdb and load that in you will get an option to load points, lines, polygons in separate layers – Mapperz Sep 16 at 16:00
  • What actually solved was renaming the folder from myfoldername to myfoldername.gdb Thank you for this hint – GabrieleMartini Sep 17 at 7:36
1

Finally this is the procedure that works:

  1. Install QGIS and gdal-filegdb as described here Installing QGIS with FileGDB?
  2. Make sure the directory name ending is .gdb (renaming the directory solved the issue in my case)
  3. Open the directory as described here Installing File Geodatabase (*.gdb) support in QGIS? (in my case it works both selecting type ESRI FileGDB and OpenFileGDB)

Not the answer you're looking for? Browse other questions tagged or ask your own question.