2

I found recently that strange thing is happening when I right click on selected script or layer in a table of content. Some items of pop-up menu are faded:

enter image description here

If I repeat right click 3 or more times, they become available. Another option is keyboard shortcut Shift+F10, which is far from ideal. It happens on a long lists, e.g. over 15 layers in the table of content.

I am using ArcGIS 10.5.1 and I have a suspicion that this is yet another windows update, the latest I have is "Feature update to Windows 10, version 1903", early September.

This is not happening in other applications, e.g. explorer. It seems specific to ArcGIS. It looks like a minor thing, but I found it very annoying.

Are you experiencing this behavior and hopefully know how to fix it?

  • Are you certain the toolbox (.tbx) file isn't locked by another application? Perhaps you have a slow-to-close ArcMap or ArcCatalog that is holding a file lock preventing changes, you should be able to check for these in task manager, details tab, sorted by Name (just because ArcMap and ArcCatalog are close to the beginning of an alphabetical sort) if there are more instances there than you have visible or expected windows it could mean you have a locking problem. – Michael Stimson Sep 17 at 2:04
  • 1
    @Michael Stimson It is not the case, I've checked it. It also happening in ArcMap table of content, no chance of it being blocked. – FelixIP Sep 17 at 2:11
  • Have you tried renaming Normal.mxd or renaming entire folder ArcMap in: C:\Users\<users>\AppData\Roaming\Esri\Desktop10.X\ or rename normal.mxt C:\Users\<user>\AppData\Roaming\Esri\Desktop10.X\ArcMap\Templates – JuniorPythonNewbie Sep 17 at 6:54
  • @JuniorPythonNewbie I tried you suggestion, it didn't work. – FelixIP Sep 17 at 21:51
  • Can you try renaming your C:\Users\YOUR_USER\Documents\ArcGIS folder and let ArcMap creates a new one for you to see if this fixes your problem? This has fixed a totally different problem for me, but who knows... – umbe1987 Oct 8 at 9:24
1
+200

Try to rename your C:\Users\YOUR_USER\Documents\ArcGIS folder and launch ArcMap to let it re-create it from scratch. In my case, it contains these folders/files:

enter image description here

If this works, either delete or keep the renamed folder: you won't need it anymore.

This has solved a totally different problem for me (in my case, I had the size of my MXDs being huge like hundreds of MB! After I tried this, the size returned normal).

  • the mxd size goiing up could be caused by the geoprocessing history, check your setting to see if that's the case..... – J.R Oct 9 at 7:43
  • I already checked that when I had that problem and unfortunately I could not fix it. really good point though, thanks. – umbe1987 Oct 9 at 7:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.