0

I want to display layers with QGIS server, but the group layer doesn't get displayed, instead I get a bad request response from the server:

The request:

http://myserver/cgi-bin/91589/qgis_mapserv.fcgi?SERVICE=WFS&VERSION=2.0&REQUEST=GetFeature&typename=94043_CADASTRE&SRSNAME=EPSG:2154&OUTPUTFORMAT=GeoJSON

<ServiceExceptionReport xmlns="http://www.opengis.net/ogc" version="1.2.0">
  <ServiceException code="RequestNotWellFormed">
    TypeName '94043_CADASTRE' unknown
  </ServiceException>
</ServiceExceptionReport>

Server Response

enter image description here And here is a peek at the layer section in QGIS:

enter image description here Layers

  • 1
    Group layers do not make sense with WFS because the layers which belong to the group may have different schemas. You must fetch the layers one be one. – user30184 Sep 20 '19 at 17:51
  • @user30184 Okay, but when i get them out of the group, i can't even see them in the GetCapabilities response with both WFS and WMS. ??! do you have any idea why is that. All i get is bad request response and the "typename is unknown" – EL. Issam Sep 20 '19 at 18:35
  • If you do not see some layer in WFS GetCapabilities then the administrator of the service perhaps does not want to publish it through WFS. But you may suffer from some other issue as well. BTW. your screen capture shows layer 91326_CADASTRE but in the text you try to read 94043 but I guess that's not important and all, perhaps municipalities, behave in a similar way. – user30184 Sep 20 '19 at 20:54
  • You may not see the layers with a WMS GetMap request if the layers have scale layering. – nmtoken Sep 24 '19 at 6:55
1

Layer groups are a feature of the WMS service and have no meaning in the WFS service.

|improve this answer|||||
  • Even in WMS, The layers grouped in "91326_CADASTRE" ( in the image above), don't show in the response of GetCapabilities( or GetFeature). I'm afraid it's a setting in the project file. – EL. Issam Sep 22 '19 at 14:20
  • Yes that is one of the reasons to use a layer group – Ian Turton Sep 22 '19 at 17:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.