1

I am confused on how to initiate reseeding in mapproxy. I used the file mapproxy.yaml and seed.yaml for the first seeding. Its source has been significantly updated. So I want to cache everything anew. This mapproxy-seed -f mapproxy.yaml -s seed.yaml doesn't work (tiles weren't created like with the dry run setting). I failed with this too:

--reseed-interval 90d --reseed-file reseed.time \
--continue --progress-file .mapproxy_seed_progress

How can I reseed tiles? This my yaml file:

# ---------------------------------------
# MapProxy example seeding configuration.
# ---------------------------------------
#
# This is a minimal MapProxy seeding configuration.
# See full_seed_example.yaml and the documentation for more options.
#

seeds:
  myseed1:
    caches: [osm_cache]
    # grids: []
    # coverages: []
    levels:
      to: 12
   # refresh_before:
    #  time: 2013-10-10T12:35:00

#cleanups:
 # myclean1:
  #  caches: [osm_cache]
   # remove_before:
    #  days: 14
    #levels:
     #   from: 11

#coverages:

# -------------------------------
# MapProxy example configuration.
# -------------------------------
#
# This is a minimal MapProxy configuration.
# See full_example.yaml and the documentation for more options.
#

# Starts the following services:
# Demo:
#     http://localhost:8080/demo
# WMS:
#     capabilities: http://localhost:8080/service?REQUEST=GetCapabilities
# WMTS:
#     capabilities: http://localhost:8080/wmts/1.0.0/WMTSCapabilities.xml
#     first tile: http://localhost:8080/wmts/osm/webmercator/0/0/0.png
# Tile service (compatible with OSM/etc.)
#     first tile: http://localhost:8080/tiles/osm/webmercator/0/0/0.png
# TMS:
#     note: TMS is not compatible with OSM/Google Maps/etc.
#     fist tile: http://localhost:8080/tms/1.0.0/osm/webmercator/0/0/0.png
# KML:
#     initial doc: http://localhost:8080/kml/osm/webmercator
services:
  demo:
  tms:
    use_grid_names: true
    # origin for /tiles service
    origin: 'nw'
  kml:
      use_grid_names: true
  wmts:
    # use restful access to WMTS
    restful: true
    # this is the default template for MapProxy
    restful_template: '/{Layer}/{TileMatrixSet}/{TileMatrix}/{TileCol}/{TileRow}.{Format}'
    # and also allow KVP requests
    kvp: true
  wms:
    md:
      title: MapProxy WMS Proxy
      abstract: This is a minimal MapProxy example.

layers:
  - name: osm_background
    title: osm_background
    sources: [osm_cache]

caches:
  #geoserver cache:
  gasps_osm_cache:
    # cache the results in two grids/projections
    grids: [osm_grid]
    sources: [osm_source]

sources:
  gasps_osm_source:
    type: wms
    req:
      url: 'http:/xxx.local:xxxx/geoserver/wspace/wms'
      layers: wspace:layer
grids:
    osm_grid:
        base: GLOBAL_MERCATOR
        srs: 'EPSG:3857'
        origin: nw

globals:


  • you say you failed, what went wrong? – Ian Turton Sep 25 at 11:35
  • I solved it by adding refresh_before setting. Failed cause seeding looks like run with -n key (dry run). 0 tiles were creted. – Tyomik_mnemonic Sep 25 at 13:38
2

You have to set refresh_before or cleanups : remove_before: setting in your seed.yaml. Without them new tiles will not be created.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.