0

I am using macOS Mojave and Homebrew with latest update. I have tried to install gdal 3.0.1 and filegdb plugins via homebrew-osgeo4mac tap as below:

brew tap osgeo/osgeo4mac
brew install osgeo-gdal
brew install osgeo-gdal-filegdb

After complete, I could not find FileGDB on the listed format after checking via ogrinfo —formats only OpenFileGDB on the list with read-only support

How to enable write support for FileGDB in macOS? I have follow various solution that already answered in this forum with no success.

For comparison, I installed GDAL+FileGDB plugin from gisinternals repo in Windows 10, and FileGDB on the list with write support.

1

I think I solved my own problem. So its because gdal and filegdb has different version (v3.0.1 vs v2.4.1) and not symlink correctly to /usr/local/lib/gdalplugins/3.0

What I did, change line 4 in osgeo-gdal-filegdb.rb with latest gdal 3.0.1 link from osgeo-gdal.rb in line 23 Then do brew upgrade osgeo-gdal-filegdb

rw enabled for filegdb

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.