I have layers that have been loading fine in my ArcMap project but now they load in for a second, and then when annotation begins to load in, everything but the annotative text goes white. So the layers are showing up and then disappearing. This is not a scale or zoom issue. Layers load in briefly at all scales and then always disappear.

I was doing copy/paste of text boxes and moving them around to label parcels with specific data when this happened all of a sudden. Process was working fine, as it always had until the map was refreshing, as it does multiple times, and then white map happened. Tried a restart, tried eliminating possible trouble layers, all computer drivers are up to date. No idea what is happening.


I am using Data Driven Pages with an attribute field for Rotation. Under the data frame properties, under general, this field applies a rotation value. If I change it back to "0" everything loads in as it used to. Once I re-apply the data frame attribute for rotation, its back to the issues of loading for a brief second.

----UPDATE #2----

I have resolved the issue. There was a copied and pasted label that creating issues. I went to "Data View" and did a "Full Extent". Once everything finally stopped refreshing there was a label that was taking up the whole frame. I removed it and everything is back to normal.

  • Are the layers you are loading rasters or vectors? If they are raster layers, how large are the file sizes? If they are vectors, how many features (i.e. rows in attribute table) do they contain? I'm thinking this is a rendering issue.
    – Kartograaf
    Sep 25, 2019 at 20:18
  • Both. That's the strange part is that is is a mixture of multiple types of layers, all with small tables/data. Much smaller than most of the maps I have been working on. As the map refreshes, all layers are displayed fine during the process, as it finishes, they then disappear. This map was working fine for days and then all of a sudden its now doing this without any change in input other than copy/paste a of a text box. Removing the annotative layers do not help either. Sep 26, 2019 at 21:13
  • Are these layers you've georeferenced? Rotating those can cause problems.
    – recurvata
    Sep 27, 2019 at 13:48

1 Answer 1


You should look at the visible scale range of your layers under properties->general. I'm guessing that your layers are set to only display at certain scales, which is often the case with high resolution GIS datasets. You can change the settings to display at whatever scale you would like to see them.


  • That is not the issue. As i mentioned, this is not a scaling or zoom problem. I have checked all the typical scaling issues and these layers were loading in fine one second and then without any changes made to the map they are now loading white after briefly being visible during the refresh process. It's odd. Sep 26, 2019 at 21:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.