1

I am trying to add a protected Arc layer to a QGIS project and have had no success.

What I have tried so far:

1) Generate token using the token service url... enter image description here

2) Create a QGIS authentication configuration... enter image description here

3) Enter the service url... https://geodata-services.drillinginfo.com/arcgis/rest/services/Landtrac/DI_Landtrac_Units/FeatureServer enter image description here

When attempting to add the layer I get...

Failed to retrieve service capabilities: Error 499: Token Required

However, if I append the token to the url with: url?token=mytoken, I am able to see the layer in the list...

enter image description here

But I am unable to add the layer to the map... I receive error:

2019-09-26T12:52:55 CRITICAL Layer is not valid : The layer authcfg='10ph3f0' bbox='-1.13707e+07,3.75972e+06,-1.13549e+07,3.76784e+06' crs='EPSG:3857' filter='' url='https://geodata-services.drillinginfo.com/arcgis/rest/services/Landtrac/DI_Landtrac_Units/FeatureServer?token=mytoken/0' table="" sql= is not a valid layer and can not be added to the map. Reason: AFSProvider getLayerInfo failed

1

I had what seemed to be the same errors, on a different server of course. It worked after I reduced the url, deleting everything after /arcgis/rest/services/

If you try that it takes a long time to load the list of layers for me to choose the one I want, but that's better than not being able to use it at all.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.