6

I just installed QGIS 3.4 on my computer (macOS Sierra 10.12.6) and I'm trying to install QuickMapServices, but I'm unable to. My plugins window looks like this:

QGIS plugins

and the settings tab says "The settings on this tab are only applicable for Python Plugins. No Python support detected, thus no settings available":

settings

I downloaded QuickMapServices from the QGIS Python Plugin Repository, but I can't access it. I have Python 3.6.0 on my computer.

2

3 Answers 3

2

Update your Mac OS to High Sierra 10.13 or higher. This worked for me.

https://qgis.org/en/site/forusers/download.html

enter image description here

2

I had the same issue in Windows while using QGIS 3.16. So this is for anyone using Windows.

Check this site on installing Python packages https://landscapearchaeology.org/2018/installing-python-packages-in-qgis-3-for-windows/

You might realize you are missing the following .dll files

  • api-ms-win-crt-process-l1-1-0
  • api-ms-win-crt-conio-l1-1-0

Install them then proceed with the installation provided in the link.

0

For Linux the following helped: install qgis-server python-qgis qgis

# Debian-based, as e.g. Ubuntu    
if [ -f "/etc/debian_version" ]; then
    sudo apt install qgis-server python-qgis qgis
fi

# Red-Hat-Based, as e.g. Fedora:
if [ "$(grep -Ei 'fedora|redhat' /etc/*release)" ]; then
    sudo dnf install qgis-server python-qgis qgis
fi

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.