Windows 10. I've not used my 3 installations of QGIS for 6 weeks maybe. I updated them via OSGeo4w but I get the error "The code execution cannot proceed because OpenCL.dll was not found. Reinstalling the program may fix the problem". enter image description here

OSGeo4w gives me the error

Package: qgis-common qgis-common.bat exit code -1073741515. Package: qgis-ltr-common qgis-ltr-common.bat exit code -1073741515

Attempting to open any of the QGIS installations gives me the error enter image description here

Reinstalling the programmes produces the same errors. Can anyone help please?

  • This may well be a Windows 10 issue that is not allowing correct installation/opening of the OSGeo4W programmes?
    – IanGS
    Sep 27, 2019 at 21:45
  • 1
    OpenCL is used for parallel processing for example in gdal. OSGeo4W comes wirh a opencl.dll and tries to install it through the qgis installation process. Did you install QGis with administrator privileges? Sep 28, 2019 at 6:30
  • I've tried that 2 times, same errors occur. I have 4 QGIS installations as part of the process. I get the error 'The code execution cannot proceed because OpenCL.dll was not found. Reinstalling the program may fix the problem' for each of the 4 installations - 4 error windows.
    – IanGS
    Sep 28, 2019 at 8:18
  • Tried to uninstall (not reinstall) all QGIS versions and I received the same error messages. They seem to be NOT uninstalled.
    – IanGS
    Sep 28, 2019 at 9:37
  • How can you have errors after uninstalling qgis? And what do you mean with having 4 Installations? Which Installer do you use? Where has QGIS been installed? There should be a directory: C:\OSGeo4W or OSGeo4w64. Inside is a folder named bin and it should contain opencl.dll. This will be copied to the Windows system directory when installing qgis. I guess your error with qgis-common.bat rised during the installation? I think you should investigate, why this happens. The bat file is located under osgeo4w\etc\postinstall and can run it from a OSGeo Command Shell. Sep 28, 2019 at 13:30

1 Answer 1


I encountered a similar issue while installing QGIS 3.34 via OSGeo4W after a fresh Windows 10 installation. After trying for hours, I was able to solve the problem by applying the following:

  • Uninstall QGIS via OSGeo4W Setup.
  • Rename existing OpenCL.dll in c:\Windows\System32, Or delete... because OSGeo installation adds opencl.dll if not exists.
  • Run QSGeo Setup as Administrator.

It is also possible that you get the same error due to a different reason.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.