0

I am accessing WMTS data in QGIS 3.8 (and QGIS 3.4) from a GeoServer at the following address:

https://gis.lmi.is/geoserver/gwc/service/wmts?REQUEST=GetCapabilities

The layer is LMI_Kort and the WMTS tiles are served via a GeoWebCache. The data appear distorted/aliased, with zig-zag effects on straight lines e.g. roads. It happens in the native projection and if reprojected. I have tried setting the zoom level (via Scale box on GUI) to match the levels for which the tiles were created e.g. 1:10,000, 1:25,000, 1:50,000 etc., but it doesn't help.

There are no issues when the same layer is viewed directly from the WMS server, however WMS is significantly slower:

https://gis.lmi.is/geoserver/ows?version=1.3.0

There is some discussion of a similar issue on the QGIS mailing list (http://osgeo-org.1560.x6.nabble.com/WMS-GeoWebCache-image-quality-in-QGIS-td5157450.html) but it is unresolved.

All the WMS/WMTS options are set to their defaults. Is there a way to configure QGIS to render the WMTS tiles without distortion?

Update:

I tried using the TMS URL to add the layer as XYZ tiles:

https://gis.lmi.is/geoserver/gwc/service/tms/1.0.0/LMI_Kort@EPSG%3A3857@png/{z}/{x}/{y}.png

This brings in tiles in strange locations. If I use {-y}, to invert the y axis, I don't get any tiles at all.

Update:

Using different DPI-Mode settings when adding the WMTS connection in QGIS doesn't help. (all, off, QGIS, UNM, GeoServer)

Update:

Using the different scales provided in the demonstration maps on the GeoServer e.g. 1:273k doesn't help.

Update:

The effect is the same on both a hi-dpi laptop screen and a normal desktop monitor.

2
  • The zoom levels reported in QGIS may not match the actual zoom levels the tiles were created at. You'll need to work out if the WMS is following the OGC specification for dpi (For the purposes of this International Standard, the common pixel size is defined to be 0,28 mm × 0,28 mm.) or something else
    – nmtoken
    Oct 2 '19 at 16:27
  • 2
    The zoom levels in the gridset demonstrator don't match those 1:10,000, 1:25,000, 1:50,000 scales, instead we have 1:68K, 1:34K,1:17K... wonder if that is the root of the issue
    – nmtoken
    Oct 3 '19 at 11:34
1

I looked at this again in QGIS 3.14.1. I can right-click on the WMTS layer and click "Zoom to Native Resolution (100%)". This jumps to the nearest zoom level that gives clean lines. It seems that this option was added in QGIS 3.8 but I'm note sure that I noticed it then.

For reference, the original map server has been removed, too, and the service is now available at:

https://gis.lmi.is/mapcache/wmts?service=wmts&request=getcapabilities&version=1.0.0

The zoom layers were at levels such as 1:18056, 1:36112, 1:72224 etc.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.