4

Summarize by right clicking the field in the table of attributes is giving wrong calculations in some cases. We think is because of null values.

The following table is a subset of a larger (>200k objects) table but the results of this subset are already erroneous.

enter image description here

When summarizing the field "name" by right clicking in the table we get these results:

enter image description here

Magnolia and Yucca should give null results in the statistics. Certainly not a min/max of 1 in the case of Magnolia. The full table gives even stranger results. Running the same operation from the processing toolbox Summary Statistics gives the expected and correct results:

enter image description here

This is a major problem that worries us a lot, since this tool is one of the most frequently used and who knows how many times we may have given wrong results.

We have tried this in three different users and computers from ArcMap versions 10.6.1 and 10.3.1 with the same results so it seems it is an old problem. We are opening a case with ESRI. I will comment on the answer from them.

I would be interested to know if someone has encountered the same problem or has some theories. This can lead to errors that are difficult to spot sometimes so I wanted to share this as a question but also as a warning for users using this tool.


Edit: We got a first response from ESRI. They say they are aware of this problem and there is a Bug NIM084228.

enter image description here They are aware of this since 2012, version 10.1!!

Currently, there are no plans to address this in ArcMap.

I really don't get it. So they know, they don't care, they won't fix it but the tool stays in every next release without even adding a miserable disclaimer.

1

As you say in an answer that you have included within your question this appears to be Bug NIM084228:

Summarizing attribute tables return incorrect results with null values.

Esri have therefore acknowledged that this bug exists in ArcMap. ArcMap uses an architecture that is 20-25 years old, and which was superseded by ArcGIS Pro a number of years ago.

Consequently, I think that you should test whether this works as expected in the latest release of ArcGIS Pro, and if it does not, then report it as a bug in that application.

If you wish to continue using ArcMap, rather than ArcGIS Pro, then as @hornbydd has commented you can always use the Summary Statistics which has an advantage of inserting a log into the metadata.

Not the answer you're looking for? Browse other questions tagged or ask your own question.