4

My apologies, this is quite certainly a duplicate of an old question, but I cannot find the answer. I am struggling with drawing polygons in the new QGIS 3.8.3 on Mac.

In QGIS 2 drawing polygons was as simple as enabling the editing mode, clicking the "Add Polygon" button, drawing the polygon by clicking and then right-clicking (Ctrl + click on the trackpad). After this, a pop-up would come and ask to add Feature Attributes.

In QGIS 3.8 everything works relatively similar until the right-click. Nothing happens. Only Esc works and removes the polygon (as it should). Which button am I supposed to press?

?

3 Answers 3

2

I found it! In the settings of my mac, I selected "bottom right click" in my trackpad to act as a secondary click aka right click. So when I click the bottom right of my trackpad, its essentially a right click which allows me to complete the polygon!

1
  • Thank you Rayna. That, indeed, works for me too. For those who wonder what is meant by "bottom right-click", see here: macpaw.com/how-to/right-click-on-mac. Seems like this is a bug which will (hopefully) be fixed in future releases.
    – Mikko
    Oct 12, 2019 at 18:10
1

Looks to be a bug:

https://github.com/qgis/QGIS/issues/31279

I would comment on that saying you are experiencing the same issue and use 2.18 in the meantime.

0

Assuming you have fields in the layer you are editing,

1) Select Settings > Options

2) Click on the Digitizing tab

3) Deselect Suppress attribute form pop-up after feature creation

enter image description here

*Note: if there are no fields in the layer, the form will not open.

1
  • Thank you for your answer. Unfortunately, this does not help, as the option is already deselected.
    – Mikko
    Oct 4, 2019 at 7:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.