Through QGIS I loaded an OSM file I created and I'm trying to visualize what happens with the file in terms of codes after some modifications like adding points, lines or polygons. But the problem is that when I save the file with the OpenStreetMaps plugin the modifications don't appear as I was expecting...

Here you can see the file I created and if you want, feel free to do the same test adding points or whatever, saving and then see if something changes in the new saved file.

<?xml version="1.0" encoding="UTF-8"?>
<osm version="0.6" generator="OpenStreetMap server">
<bounds minlat="52.2615973629" minlon="10.5262132592" maxlat="52.2653605629" maxlon="10.5313793802"/>
<node id="100" lat="52.264859" lon="10.528042" version="1" user="ribe_lu" visible="true" timestamp="2012-09-10T13:47:15Z"/>
<node id="101" lat="52.264859" lon="10.529796" version="1" user="ribe_lu" visible="true" timestamp="2012-09-10T13:47:15Z"/>
<node id="102" lat="52.262619" lon="10.528042" version="1" user="ribe_lu" visible="true" timestamp="2012-09-10T13:47:15Z"/>
<node id="103" lat="52.262619" lon="10.529796" version="1" user="ribe_lu" visible="true" timestamp="2012-09-10T13:47:15Z">
    <tag k="made_by" v="Lucas"/>
<node id="104" lat="52.264186" lon="10.529078" version="1" user="ribe_lu" visible="true" timestamp="2012-09-10T14:20:17Z"/>
<node id="105" lat="52.26326" lon="10.529078" version="1" user="ribe_lu" visible="true" timestamp="2012-09-10T14:20:17Z"/>
<node id="106" lat="52.26326" lon="10.528801" version="1" user="ribe_lu" visible="true" timestamp="2012-09-10T14:20:17Z">
    <tag k="made_by" v="Lucas"/>
<way id="25" visible="true" timestamp="2011-01-09T14:05:48Z" version="1" user="ribe_lu">
    <nd ref="100"/>
    <nd ref="101"/>
    <nd ref="103"/>
    <nd ref="102"/>
    <nd ref="100"/>
    <tag k="area" v="yes"/>
    <tag k="Schloss" v="Arkaden"/>
    <tag k="Postal_Code" v="38100"/>
<way id="26" visible="true" timestamp="2011-01-09T14:05:48Z" version="1" user="ribe_lu">
    <nd ref="104"/>
    <nd ref="105"/>
    <nd ref="106"/>
    <nd ref="104"/>
    <tag k="Test_by" v="Lucas"/>
<relation id="75" visible="true" timestamp="2012-09-10T14:50:10Z" version="1" user="ribe_lu">
    <member type="way" ref="25" role="outer"/>
    <member type="way" ref="26" role="inner"/>
    <tag k="type" v="multipolygon"/>

I am not sure how you worked with the plugin. Normal procedure is to load data, modify it, and then upload it. If you miss the last step, the data will still have local (negative) ids, and have no version or timestamp information. That might be the reason why it does not get saved.

I would favour to use the JOSM editor for local-only editing.

  • There is a Save to OSM button: documentation.qgis.org/html/ru/_images/osm_save.png That does not seem to be saving all edits for me. – Devdatta Tengshe Jan 2 '13 at 15:30
  • 1
    Yes, I have used it also. It does not work, before you uploaded the data to the OSM server. Furthermore, your Qgis Project should be in EPSG:4326, that is WGS84 lat/lon. Thats the only CRS the OSM server accepts. And you have to be registered at OSM to upload data. – AndreJ Jan 2 '13 at 15:41

You need to log in on the plugin and then upload the data to OSM, otherwise use JOSM to save local. There is also the projection error that is relevant. This was all mentioned above but I have found it true in my experience as well. OSM data that is downloaded asnd worked localy is broken due to lack of correct reprojection. Idealy the data would be unprojected or in the same projection with a straight conversion.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.