2

I struggle to edit my project in QField on a Samsung Galaxy Tab Active 2. The general idea would be to create and edit points in the field and save them in a PostgreSQL db (offline and online).

What I did so far is the following:

  1. I created a portable project in QGIS (My project consists of a simple WMS base map and a "mask" that opens when creating a new point asking for the attributes of that point. This layer's source is the postgresql db. Editing and saving to the database works in the QGIS project.)
  2. Exported the project via Qfield sync as a package for QField
  3. Saved the package on the tablet under: internaldata/Android/Data/ch.opemgis.qfield
  4. Opened the project in QField on the tablet

-> The project will distplay perfectly but is not editable.

The Log-message says everywhere that the connection to database failed (PostGIS) and that editing cannot be started (QField).

To test this error, I set the layer in the QField sync project configuration to offline editing (so that it won't search for a db connection online). However, the log stays the same. This is why I believe that not being able to edit anything is an error that is based on some database connection mistake.

  • Try this: in QGIS, when you create your PostGIS connection to load the layers, tick Store in the credentials : i.imgur.com/kNIZlOr.png – Léo M Oct 10 '19 at 8:48
  • thx! I set up the project with a new layer having the credentials stored, however that still does not work (gives me the exact same log). – Lara Oct 10 '19 at 11:55
  • Just to make sure: the database is really online and not on a PG installed on your computer in localhost ? – Léo M Oct 10 '19 at 12:25
  • And is SSL disabled in your PG connection ? see here the definition of a connection that works (it's the postgis online example project of QField) : i.imgur.com/l6IeSBC.png – Léo M Oct 10 '19 at 12:30
  • Yes, the data base is online (not local) and SSL is disabled. I just tried the QField example by creating a new PG layer as you said. Weirdly, the log-message still shows exacly the same and says that it is unable to connect to my db (even though this is the demo db from QField). It seems that the log does not refresh. – Lara Oct 10 '19 at 13:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.