1

I'm looking into how much open and close canopy falls within given buffer zones. My buffer zones are a polygon layer created from point sites, but canopy data is a raster with 2 types of data, open or closed canopy. It was pulled from PASDA and has a fairly fine resolution, which is why some other solutions (Converting to polygon) did not work.

This is my first time using ModelBuilder, but I'm attempting to use the tabulate area tool in ModelBuilder by iterating through each row of my buffer zones, tabulating area, and then collecting the new tables. Finally, I use a second model (With the iterating model as a sub-model) to merge these tables together into one output (Added images of models).

However, I'm getting error 001156 (Attached screen shot of error) at the end.

Does anyone have a suggestion to get around this?

It suggests that the string length of columns is limited (This doesn't seem to be the case), or that there is data of one type being written to a column that contains a separate data type. All of the columns from Tabulate area are the same, however.

Unfortunately, I cannot include a screenshot of my tables as they contain locality information for sensitive species. The tables from Tabulate Area have 4 columns (Object ID, Name, Closed Canopy, Open Canopy)

https://imgur.com/a/lpJVe8x

  • The error starts at the second row. Is there a way to adjust the amount of allowed characters after using Tabulate area, but before merge? – Jon Adamski Oct 15 '19 at 2:04
  • Why are you iterating your input features? If you have a selection buffer will work with only the selected features; give each of your input features a unique ID (not FID or OBJECTID) it will be maintained in the buffer polygons, run the tabulate value with Zone Field as the unique ID for each input then your tabulated areas will contain the ID of the input feature. Though if you have overlapping buffers I can see why iteration is necessary.. but create your output feature class first and add nice long string fields then use append instead of merge to bring the data together. – Michael Stimson Oct 15 '19 at 2:32
  • Yes, it's due to the overlapping buffers. Each site has a unique name, and this is what I'm using to group by in the tabulate area tool. The string length for the Name column is 254, so I'm unsure why it's throwing this error as none of the names are anymore near that high. I'll try running using append instead. – Jon Adamski Oct 15 '19 at 2:55
  • I created a new, empty table with the same column names as the output from Tabulate Area. It would not populate the table with append.I then renamed one of the tables created from Tabulate Area (As these should be the same columns), and tried once again. It's returning the same error that the merge tool threw. – Jon Adamski Oct 15 '19 at 3:27
  • That's odd, are there any unicode characters in that row? – Michael Stimson Oct 15 '19 at 4:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.