4

enter image description hereI drew a polygon, and then went to delete the layer I drew it in, but it didn't delete the polygon. I know have a random red shape that isn't attached to any of my layers in the middle of my project. Even if I disable all the layers, the shape remains. How do I get rid of it?

  • 2
    Could you please provide a screenshot? – Erik Oct 21 at 11:30
  • 2
    How did you drew the polygon ? – J.R Oct 21 at 11:32
5

It sounds like you still have it identified.

Choose the identify tool and click somewhere else, the red outline should disappear.

Edit based on comments:

With the picture now, it looks like an unfinished polygon. So when you are editing, and start creating a polygon and never right click to finish it. It is saved until you return to editing that layer. Save the project and restart QGIS, that should remove it.

  • You're right. I suspected the same, quite a common "mistake". – Erik Oct 21 at 11:44
  • I tried that, it just selects something else and nothing happens to the polygon – Saffy Oct 21 at 11:49
  • With the picture now, it looks like an unfinished polygon. So when you are editing, and start creating a polygon and never right click to finish it. It is saved until you return to editing that layer. Save the project and restart QGIS, that should remove it. – HeikkiVesanto Oct 21 at 11:52
  • 1
    Restarting QGIS got rid of it, can't believe I didn't try that myself! Thank you :) – Saffy Oct 21 at 11:55
  • 2
    Usually you can fix this issue without restarting QGIS. Just start drawing a new feature in any polygon layer. The leftover unfinished polygon will either become active and allow you to continue drawing it, or it will disappear. Right click to finish drawing, and hit escape to discard it. – csk Oct 21 at 14:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.