A recent issue I've encountered with Mapbox Studio is the apparent inability to upload a geojson as anything other than a collection tileset, instead of a point, line, or polygon tileset. For example, the old tileset (circled in black) shows the line icon where the new one (circled in blue) shows the collection icon.

Screenshot of Tileset Selection

My difficulty lies in updating the style. When I go to switch out the data Mapbox Studio detects the different data type and resets the style...which means I have to style that layer by hand each time I update the information. This becomes time consuming when the tileset is used on 15+ layers. So far Mapbox's response has been to "update the style" which is not helpful as that's what I'm trying to do.

I put the geojson into a text editor to remove "feature collection" and just make it a list of features, but Mapbox won't upload it and errors out. I created a dataset directly in Studio but when exported to a tileset the same thing happens (becomes a collection instead of line). I have also tried this with data that contained a single polygon or a single point and encounter the same issue.

Does anyone have any suggestions? I tried adjusting the data so maybe the issue is in learning how to save the styling information or preventing the style from clearing when a different data type is detected?

  • You're not the only one who's noticed this. Your best bet is reaching out to Mapbox Support about the issue. Commented Oct 25, 2019 at 6:48

1 Answer 1


Mapbox has resolved the bug. I had entered a help ticket with them about this and they were able to recreate the issue. But it's fixed now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.