1

I am currently facing an issue with QGIS 3.8.3. In which I am unable to use Vector Tools and other plugins. Missing Vector Tools

Below are some of the trackbacks for the Python error. I am unable to show all due to the word count when posting the question:

Couldn't load plugin 'processing' 

OSError: [WinError 193] %1 is not a valid Win32 application 
Traceback (most recent call last):
  File "C:/PROGRA~1/QGIS3~1.8/apps/qgis/./python\qgis\utils.py", line 312, in loadPlugin
    __import__(packageName)
  File "C:/PROGRA~1/QGIS3~1.8/apps/qgis/./python\qgis\utils.py", line 737, in _import
    mod = _builtin_import(name, globals, locals, fromlist, level)
  File "C:/PROGRA~1/QGIS3~1.8/apps/qgis/./python/plugins\processing\__init__.py", line 25, in 
    from processing.tools.general import *              # NOQA
  File "C:/PROGRA~1/QGIS3~1.8/apps/qgis/./python\qgis\utils.py", line 737, in _import
    mod = _builtin_import(name, globals, locals, fromlist, level)
  File "C:/PROGRA~1/QGIS3~1.8/apps/qgis/./python/plugins\processing\tools\general.py", line 32, in 
    from processing.core.Processing import Processing
  File "C:/PROGRA~1/QGIS3~1.8/apps/qgis/./python\qgis\utils.py", line 737, in _import
    mod = _builtin_import(name, globals, locals, fromlist, level)
  File "C:/PROGRA~1/QGIS3~1.8/apps/qgis/./python/plugins\processing\core\Processing.py", line 54, in 
    from processing.algs.qgis.QgisAlgorithmProvider import QgisAlgorithmProvider  # NOQA
  File "C:/PROGRA~1/QGIS3~1.8/apps/qgis/./python\qgis\utils.py", line 737, in _import
    mod = _builtin_import(name, globals, locals, fromlist, level)
  File "C:/PROGRA~1/QGIS3~1.8/apps/qgis/./python/plugins\processing\algs\qgis\QgisAlgorithmProvider.py", line 76, in 
    from .HypsometricCurves import HypsometricCurves
  File "C:/PROGRA~1/QGIS3~1.8/apps/qgis/./python\qgis\utils.py", line 737, in _import
    mod = _builtin_import(name, globals, locals, fromlist, level)
  File "C:/PROGRA~1/QGIS3~1.8/apps/qgis/./python/plugins\processing\algs\qgis\HypsometricCurves.py", line 25, in 
    import numpy
  File "C:/PROGRA~1/QGIS3~1.8/apps/qgis/./python\qgis\utils.py", line 737, in _import
    mod = _builtin_import(name, globals, locals, fromlist, level)
  File "C:\Users\jerom\AppData\Roaming\Python\Python37\site-packages\numpy\__init__.py", line 140, in 
    from . import _distributor_init
  File "C:/PROGRA~1/QGIS3~1.8/apps/qgis/./python\qgis\utils.py", line 737, in _import
    mod = _builtin_import(name, globals, locals, fromlist, level)
  File "C:\Users\jerom\AppData\Roaming\Python\Python37\site-packages\numpy\_distributor_init.py", line 26, in 
    WinDLL(os.path.abspath(filename))
  File "C:\PROGRA~1\QGIS3~1.8\apps\Python37\lib\ctypes\__init__.py", line 356, in __init__
    self._handle = _dlopen(self._name, mode)
OSError: [WinError 193] %1 is not a valid Win32 application


Python version: 3.7.0 (v3.7.0:1bf9cc5093, Jun 27 2018, 04:59:51) [MSC v.1914 64 bit (AMD64)] 
QGIS version: 3.8.3-Zanzibar Zanzibar, 685d8b15d2 

Python Path:
C:/PROGRA~1/QGIS3~1.8/apps/qgis/./python
C:/Users/jerom/AppData/Roaming/QGIS/QGIS3\profiles\default/python
C:/Users/jerom/AppData/Roaming/QGIS/QGIS3\profiles\default/python/plugins
C:/PROGRA~1/QGIS3~1.8/apps/qgis/./python/plugins
C:\Program Files\QGIS 3.8\bin\python37.zip
C:\PROGRA~1\QGIS3~1.8\apps\Python37\DLLs
C:\PROGRA~1\QGIS3~1.8\apps\Python37\lib
C:\Program Files\QGIS 3.8\bin
C:\Users\jerom\AppData\Roaming\Python\Python37\site-packages
C:\Users\jerom\AppData\Roaming\Python\Python37\site-packages\win32
C:\Users\jerom\AppData\Roaming\Python\Python37\site-packages\win32\lib
C:\Users\jerom\AppData\Roaming\Python\Python37\site-packages\Pythonwin
C:\PROGRA~1\QGIS3~1.8\apps\Python37
C:\PROGRA~1\QGIS3~1.8\apps\Python37\lib\site-packages
C:\PROGRA~1\QGIS3~1.8\apps\Python37\lib\site-packages\win32
C:\PROGRA~1\QGIS3~1.8\apps\Python37\lib\site-packages\win32\lib
C:\PROGRA~1\QGIS3~1.8\apps\Python37\lib\site-packages\Pythonwin
C:/Users/jerom/AppData/Roaming/QGIS/QGIS3\profiles\default/python
C:\Users\jerom\AppData\Roaming\Python\Python37\site-packages\IPython\extensions
C:\Users\jerom\AppData\Roaming\QGIS\QGIS3\profiles\default\python\plugins\mmqgis/forms

I have re-installed QGIS many times and I am still facing this issue.

Any help or advice for this?

  • 1
    how are you installing QGIS? are you installing the 32 or 64 bit version? – Ian Turton Oct 26 '19 at 8:18
  • @IanTurton Hi Ian! Thank you for your reply! I am installing the 64 bit Standalone version of QGIS. – Jerome Quah Oct 26 '19 at 8:19
  • I was wondering if any pip installs of python modules via the Command Prompt could have resulted in this error. I did install python modules like numpy, sklearn and mlrose for my other python projects yesterday before opening QGIS today and discovering this issue. – Jerome Quah Oct 26 '19 at 8:32
  • it looks like it is trying to run the 64bit version as a 32 bit program - how are you installing qgis? – Ian Turton Oct 26 '19 at 14:41
  • Hi @IanTurton ! Thank you for your reply! I am installing it via the QGIS homepage, the 64-bit Standalone version to be exact – Jerome Quah Oct 27 '19 at 7:25
0

Issue resolved by installing the 32bit version of QGIS.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.