1

Installed QGIS 3.4 and then 3.10, both gave errors "Grass was not found in /usr/local/opt/osgeo-grass/grass-base" In both cases the directory /usr/local/opt/osgeo-grass/ did not actually exist. I tried manually installing grass both with brew install and Grass 7.7 from grass-7.7dev.dmg.zip from the website. I tried setting the path for grass in QGIS to /Applications/GRASS-7.7.app and a few other locations that I forgot now.

All I need to do is create a flow accumulation raster from a DEM I have. I tried using the SAGA plugin in QGIS and that failed, wasn't able to generate a raster. I feel like my plugins have not been compiled correctly. However the base QGIS raster analysis works: I could create slope, aspect rasters sucessfully. The contents of my /usr/local/opt are currently

ant lcms2 osgeo-libgeotiff ant@1.10 libcryptopp osgeo-libkml armadillo libdap osgeo-libspatialite arpack libev osgeo-netcdf boost libevent osgeo-postgresql boost@1.71 libffi osgeo-proj brotli libiconv pcre c-ares libidn pcre1 cfitsio libidn2 perl cgal libjpeg perl@5.30 cryptopp libjpeg-turbo pkg-config curl-openssl libjpg pkgconfig eigen libkml-dev popt epsilon libmetalink python expat libmpc python2 fftw libpng python3 freexl libpq python@2 gcc libssh2 python@3 gcc@9 libtiff pzstd gdal2 libtool qhull gdbm libunistring readline geos libxml2 rtmpdump gettext libzip sfcgal giflib little-cms2 sqlite glib mdbtools sqlite3 gmp mpfr swig hdf4 nghttp2 swig@4 hdf5 numpy swig@4.0 hdf5@1.10 numpy@1.17 szip hwloc open-mpi tcl-tk icu4c openblas unixodbc isl openjpeg webp jansson openldap wget jasper openmpi xerces-c jemalloc openssl xz jpeg openssl@1.0 zlib jpeg-turbo openssl@1.1 zstd json-c osgeo-gdal krb5 osgeo-hdf4

0

I set the path to /Applications/GRASS-7.7.app/Contents/Resources and it seems to work

  • Didn't work unfortunately, still got the error "Grass was not found in /usr/local/opt/osgeo-grass/grass-base" – Tristan Kos Nov 19 '19 at 18:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.