3

I'm trying to get a satellite image using the SentinelHub plug in.

This works, however, when I zoom in to make my other layers clearer (roads etc.) the satellite image disappears and the background becomes white.

Can anyone tell me what might be causing the problem and how to fix it?

Before zooming in:

example1

Then zooming in slightly:

example2

6

It's probably a missing tile. If that's the case, it has nothing to do with the fact that this is satellite imagery. It's because you're accessing remotely stored data that is broken up into tiles, with different resolution and tile extents at different zoom levels. There's probably an error happening between at the tile server. Or, it's possible that the data isn't available for that extent at the resolution for that zoom level. Some tile servers will display an error message when a tile is missing, usually something like, "imagery not available at this zoom level."

Sometimes you can get the missing tile to load by panning the map. More usually, you just can't get it. If this is a paid service, contact the service provider and complain. If it's a free service, feel free to contact the service provider, but don't expect much help.

If you know what the data source is, and if it's available for download, you can eliminate the server-related errors by downloading the imagery and storing it locally.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.