I uploaded a CSV file with DMS coordinate systems in it into QGIS. The points appeared on the white background. When I add a GoogleImage background in the projected coordinate system WGSPsudoMercator, the points show on a black background. When I zoom to layer on the Google basemap, I see the points off the east coast of South Africa, they are supposed to be in Arizona, USA. Last time something similar to this happened I believe I changed the basemap from the WGS84Psudeomercator to WGS84 to align it with the points and the points showed up where I wanted them. This time, when I change the basemap projection to WGS84, the basemap disappears. I am using Degrees, Minutes, Seconds from a Juno Trimble 3B GPS. In terms of my data, I have tried switching the x field to the y-field and vise versa, adding optional numbers in front of the coordinate system such as N (for north) and W (for West), adding a negative infront of the west DMS column (the one that begins with 112). I have also tried using the other coordinates (I think LatLong or UTM), but the same problems occur. Here is the first few lines of my data in a CSV file.

enter image description here

  • If you review the DMS values in the .csv file, are they what you expect for your area of interest? Also, please define "...way off..."
    – Stu Smith
    Commented Oct 28, 2019 at 21:08
  • I did upload al my points onto QGIS, and they appeared with a white background. Then, when I added a basemap, I could only find the points off the coast of Africa in the water, and the points should be in Arizona, USA.
    – zhuba
    Commented Oct 28, 2019 at 23:33
  • Aha! Let me guess that the points are off the WEST coast of Africa. Furthermore, I'll bet that the location is very close to where the equator intersects the Greenwich Meridian; 0' latitude, 0' longitude. Arizona lat/long values, on the other hand, should be in the 35/-112 degree neighborhood (plus or minus). So, this means you've got a CRS mixup, or something's wrong with your .csv data, or... Anyway, can you edit your original post and add the first several lines from the .csv file so that others can review for you?
    – Stu Smith
    Commented Oct 29, 2019 at 1:57
  • How do I edit my comment?
    – zhuba
    Commented Oct 29, 2019 at 3:11
  • At the bottom of your question is a line of words: "share edit flag" Click the "edit" button and off you go!
    – Stu Smith
    Commented Oct 29, 2019 at 3:52

1 Answer 1


Is this correct?

enter image description here

Here's my thought process:

First, your values are clearly latitude/longitude Degree, Minute, Seconds. They are not UTM (which would look something like North 12S 364320 m east, 3823542 m north) or some other CRS (for example EPSG:2868) unit of measure, such as 530753, 1290047 feet.

Second, knowing that Arizona is the area of interest, the first column (34...) likely represents latitude, and the second column (112...) likely represents longitude. However, longitude values west of Greenwich (Hello Prescott!) are, by convention, preceded by a negative sign. That will be fixed below.

Third, I retyped (Stackexchange Pro Tip: when entering values in your question, type - or copy/paste - the values, rather than entering a screen shot. That saves retyping and avoids potential mistakes) your values in a text editor, making the following edits:

  1. Add a header line with field names, separated by commas
  2. Within the lat/long values, replace any text and punctuation (such as degree symbols and apostrophes) resulting in a single blank between D, M, and S.
  3. Insert a comma between each field value
  4. Insert a negative sign in front of the longitude values

Here's what I came up with:

1,34 32 40.662,-112 28 43.551
2,34 32 40.606,-112 28 43.333
3,34 32 40.636,-112 28 43.139
4,34 32 40.713,-112 28 43.245
5,34 32 40.834,-112 28 43.416

I saved the file as plain text, with a .csv file extension.

Fourth, I added the .csv file to QGIS as Delimited Text. Here's a screenshot:

enter image description here

Note in particular that the DMS coordinates box is checked. Also, I selected EPSG:4326 as the data's CRS - a reasonable assumption, given that it is the typical CRS used by GPS field recorders.

Voila! The points display on the QGIS map. If desired, save the points to a layer format, such as Geopackage, shapefile, etc.

  • That is correct.
    – zhuba
    Commented Oct 31, 2019 at 20:41
  • Great. If I've answered your question, please click the check mark next to my answer.
    – Stu Smith
    Commented Nov 1, 2019 at 1:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.