Sorry for such a long question.

We are trialling EnterpriseDB Postgres Plus Advanced Server 8.4 with Oracle compatibility and PostGIS 1.5.1.

I can create a connection to the database in qgis and the test connection is successful. However when I actually connect to the database to view the available tables i get the error below.

I understand that the utl_smtp is a schema related to the oracle compatibility portion of the install, so I assumed that opting for the value "Only look in the geometry_colums table" would have solved the problem. Unfortunaley not!

Has anyone else encountered this? Or more importantly solved this?

alt text




There has been a similar post on the QGIS user mailing list not long ago: [Qgis-user] Error creating a new Postgres layer - Enterprisedb

I'm quoting:

... I had sometimes similar problems when using a postgresql database which went through some commercial products, or some GUIs. Some names (tables, fields, schemas) sometimes contained uppercase letters mixed with lowercase. This caused problems in some situations (in psql, and also in qgis, if I remember well). I had to rename manually the concerned names to lowercase, and it worked. Another solution was to include the concerned names within double quotes.

I'm absolutely not sure if you are in this case; but the fact that you mentioned some third-party software rang a bell. You could check, in psql (something as "neutral" as possible, if the schema "utl_smtp" isn't "Utl_smtp" or "Utl_Smtp" or "uTL_sMtP" or anything similar...

  • I can't seem to find "utl_smtp" listed under schemas. Unfortunately i'm not too familiar with the EnterpriseDB or Advanced version of Postgres I will get in touch with our DBA tomorrow for a chat, and hopefully a resolution. Thanks Underdark, like Mapperz I was expecting you to pop up!
    – Ando
    Nov 11 '10 at 8:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.